Startup problem magic


(Rob D) #1

I have had a support ticket open and closed in this matter before – with no solution. But, since Nick graciously and publicly promised to help find the solution, I decided to make one more attempt at finding out, why Rapid Weaver prevents my computer from starting up. If nothing will come out of this attempt, I will finally give up. Here’s the background:

For about a year and a half or two years, I get this weird behaviour. If I use Rapid Weaver, and then shut down my computer, the next day my Mac can not start up. I get the grey screen with Apple logo and a spinning loading symbol. That’s it. I have to use the power-off button to get out of this predicament. Then, I start up with the R key depressed, wait for the Apple Utilities window to show, select “Reinstall from Internet” and wait about one hour for my OS to be reinstalled. After that, I am free again to start up my Mac.

I have tested extensively for some kind of a meaningful pattern in this behaviour. The only constant is opening-and-saving my project within Rapid Weaver. If I just open my project and then close Rapid Weaver without saving, all is good. But if I open RW, then SAVE (even if I do not make any change whatsoever) and close RW, next time I try to start up my computer, it refuses to do so. There is, obviously, something that the OS is looking for at the startup and it can not find it, therefore, the loading never ends…

Usually, I put my applications in folders (by categories). For example, RW app lives inside directory like that: /Applications/INTERNET/WEB-DEV/ HTML-CSS-EDITORS/RapidWeaver6. However, some companies recommend to put their applications at the root of the Applications folder. I tried both approaches – and there is no difference in Rapid Weaver affecting the startup process.

Currently, I am using 2014 MacPro with 16GB of RAM. I have about 360GB of free space on my startup disk and I’m running OS 10.9.5. But, I used to get exactly same problem on my previous computer, which was 2012 MacMini. I am using the latest version of Rapid Weaver, but the problem started back when I was still using RW4.xx and then 5.xx.

So, here it is. My question: what can be the reason that the RW use (saving process within RW) prevents my computer from starting up?
Any suggestions will be much appreciated.


(Terry Norton) #2

I’m going to assume that when you changed to a new computer you migrated your OSX user account to the new computer. Mainly because the problem is following you.

Do you have RW auto-start when you boot up?

Have you booted holding the Cmd-V keys to start in Verbose mode so you can see what is trying to load when it stops loading?

Have you tried booting while pressing the Shift key to startup in Safe Boot mode? This stops login item from loading.

One way to find out if the problem resides in your OSX user account is to create a new user on your Mac and run RW there. Just to see if you can boot after saving.

Having to re-install your whole OS just seem so Windows-like, and the extreme way to get you computer to boot up.


(Terry Norton) #3

Have you used Disk Utility to check the permissions on your hard drive?


(Nik Fletcher) #4

Some questions:

  1. Which specific version of RapidWeaver are you using now? As RapidWeaver is now sandboxed, and even though the app has never made any system changes that would affect the startup behaviour, there’s an incredibly-strong barrier around what the app can and cannot do. So I’m surprised you’re still seeing this…
  2. If you hold Option, start RapidWeaver without loading any plugins, and save a document, does this still happen?

We’ve not had any other reports of this, so I’m not sure what would cause it. I’d definitely recommend testing in a new user account: if it’s no longer happening, there is likely an app running in the background that would cause this. You may want to consider using the Safe Mode option to also test things out.

—N


(Rob D) #5

@1335Days
Yes, I migrated my account to the new computer using TimeMachine. And I know, the problem follows me that way. But I do not know which file(s) within my Library are problematic.

I do not use RW in an automatic start mode at startup. But, I have few login items that do start automatically at the time computer starts up (TrackballWorksHelper, iKey, Calendar, G-Technology Assistant). All of them (except Apple Calendar) are new items that I started using long after my RW-related problem occured).

I did try to start up in the Verbose mode. I even posted the screenshot on the old forum few months ago, but nobody had any suggestion, regarding that.

In Safe Boot mode computer does start up normally (if I remember correctly – I was doing that few months ago).

I have used Disk Utility to repair permissions about couple dozen times since this problem started.

Your suggestion about creating a new user account seems worth trying.

And yes, reinstalling my OS every time does drive me crazy, but so far, this is the only way for me to use RW and have my computer operational.

@nikf
re1. Currently, I am using RW 6.2.4.
re2. I haven’t tried that yet. Thanks for the suggestion, I will.

Thanks, guys, I will try out your suggestions and will report back tomorrow.


(Rob D) #6

OK, so I did some experimenting:

• Start RW holding Option key to disable plugins – then save (using the duplicate project file);
– disabling plugins did not help (restart impeded);
– disabling themes and plugins did not allow me to save, but it did prevent a new startup, anyway.

• Try to create new account and use RW from there – see if problem persists.
– When I copied my project to the new administrative account, RW could not open it with this message: [screenshot]. This is most likely because I do not have all my plugins and stacks installed in this new account. I will have to get in touch with addon developers to get new copies of my addons, install them in my new account and then try again.


(Terry Norton) #7

Don’t try to open an existing project because of all those dependencies associated with it. Just create a new basic RW project. We’re trying to determine if RW is some how causing your reboot problem, or if there’s something else in your OS user account that’s causing it.

Create a simple RW project and save it.

I doubt it’s OSX itself since the problem followed you to a new computer.

There’s also another thing you can try since the problem appears to be related to RW. With RW not running, delete the RW Preference files. RW will recreate them when it starts up again. This is a long-shot guess since RW seems to run properly, but then again, the issue pops up when you save in RW.

I never saw your Verbose screenshot. What was trying to load when it stopped booting?


(Rob D) #8

@1335Days
Good points.

  1. I will take a screenshot during the Verbose startup and post it here (I do not remember details from the previous screenshot);
  2. I will try to delete RW Preferences file in my old user account;
  3. I will start working with a brand new project in my new user account – once with my theme of choice (which is OUTLINE from Henk Vriselaar) and once with a random theme supplied with RW. That way, I will be able to determine whether the theme may have something to do with it.

All this may take another day, maybe more, since I have to keep my Mac operational at least for some time – to do other things, besides troubleshooting RW.

Anyways, I’m glad to have your support, guys…


(Rob D) #9

Well, there is definitely something weird going on during startup.
– I took a photo of the screen during Verbose startup, when the process stopped. I was preparing myself to take another shot (after about 2-3 minutes), when the startup began moving again and after few seconds it was completed.
– I repeated the whole process and this time, the screen showed a different record, startup never ended and I had to use power button to power-off.

See screenshots below:

P,S. I have these files in my home/Library/Preferences folder:
– com.realmacsoftware.rapidweaver6.LSSharedFileList.plist
– com.realmacsoftware.rapidweaver6.plist
– com.realmacsoftware.rapidweaverpro.LSSharedFileList.plist
– com.realmacsoftware.rapidweaverpro.plist

Do you see something redundant that shouldn’t be there? Which file do you suggest that I delete to force RW to create a new Preference file ( I am presuming that would be the second one)?


(Terry Norton) #10

Are these shots from the new User account?


(Rob D) #11

No, they are both from the old account. Have you noticed the difference in the last line of each screenshot?

What about those four files found in Preferences? I think that the last two files are leftovers from some older version of RW. What do you think?

I want to be done troubleshooting the old account before I start experimenting with the new one.


(Terry Norton) #12

I looked at my Preferences, yes, I’d say the “rapidweaverpro” plist are no longer used in RW6.

When looking through the rw6 plist I see many registration numbers. So I’m betting that deleting those probably means you’ll have to re-enter registrations. Like I said before, deleting these is probably a long-shot at best, especially since this issue was on RW5 as well, different Preference files.

I’d recommend trying the new user account first. If it follows you to the new user account, you’ll know it’s not something in your user account.

I was hoping the verbose output would provide an indication of some particular file loading that was causing the boot process to stop. Each of your screenshots ends with a hard drive file system message. So the question still remains, what is happening when RW saves?

At this point in troubleshooting it’s best to see if this is being caused by something in your user account. If it is, then the easiest remedy is to just switch to a new user account instead of trying to locate some mysterious corrupted file.


(Rob D) #13

When I deleted those 2 pref files that seemed to be leftovers from old versions, after opening RW, I was prompted to register Stacks – that proves that the pref files belonged to the old version of RW. Startup was still impeded, though.

Since the Verbose mode shows at the end a process of deleting 4 orphaned/unlinked directories, this suggests to me that there is something an old version of RW created but is still somehow connected to one of the RW components still installed. Could that be a theme or a plugin? Perhaps I should try to uninstall unused addons and install new versions? But that would mean a lot of downloading/installing/registering. The quicker method may be just deleting Prefs?

Or, should I just skip that and start experimenting with the new account? If I do skip that, I may never find out, what has caused my problems…


(Terry Norton) #14

Trying the new user account is just a test. We want to know if the current user account has some corruption somewhere.

If the new user account works ok, then you can decide if it’s worth the time to try to locate the problem or simply use the new account.


(Karen Curran) #15

HI, I noticed that you are still on Mavericks 10.9.5? I upgraded to Yosemite long ago, and I reinstalled all my apps rather than using Time Machine. And the new OS El Capitan is soon to be launched.

Sometimes it’s better to just start again with a clean slate, so to speak.
I’ve never really had any good experiences using a backup file.

I just make sure I have copies of all my work and I also copy all the plugins etc. before starting again.

Would be worth considering. Hope it all works out soon.


(Nik Fletcher) #16

I’d highly recommend that you not manually remove the .plist preference files. Since OS X 10.8, these files are loaded into memory on launch, and then written to as the system deems appropriate. Removing the files can throw OS X’s cfprefsd process into a death-spiral if the files are removed under it. If you really must remove any PLIST files, always restart your Mac immediately afterwards to avoid this issue.

—N


(Nik Fletcher) #17

This is not true of RapidWeaver 6. The PLIST files are created by the system, with RapidWeaver making changes to the preferences via a programmatic API (it does NOT read and write the PLIST file itself) so if a file like this is removed, the cfprefsd process doesn’t know how to behave and falls back to not saving any preferences until your Mac is restarted.


(Rob D) #18

@KarenC – I did not upgrade to Yosemite, because I’ve heard too many horror stories. I do plan to upgrade to El Capitan, though, because it seems that the new OS will be mainly an improvement to the current OS, like Snow Leopard was in relation to Leopard, in the past.

I have so many applications and workflows established on my Mac, that re-installing, re-registering and re-creating all the settings for them all would take me weeks or months. That’s why I use Time Machine for switching to a new OS or a new computer. But I agree, that the “clean slate” approach is more appropriate…

@nikf – This is an important info. Thanks for that. I did delete two pref files, but they were associated with some old version of RW, probably the first version I had installed in 2011.

So, my next move will be:

  1. Install Stacks2 onto RW copy inside my new user (admin) account;
  2. Create new project with the theme that I use currently, save, restart; if that impedes restart, then
  3. Create new project with a theme supplied with RW, save, restart
  4. Offer some rice and wine to gods of the digital age.

(Terry Norton) #19

Thanks for that info. Wasn’t aware.

As KarenC mentioned, some people that upgrade to a new OS like to have a clean OS and user account. Of course this requires reinstalling all apps. The benefit is that you don’t migrate potential junk files that are no longer used.

Waiting with baited breath to see what happens with the new user account.


(Rob D) #20

In the new user account, I installed RW 6.2.4, “Stacks2”, “PlusKit” and “Outline” theme from H.V. (all latest versions).

1 - I created a simple project with 3 pages: Home (text only), RW Site Map and PlusKit, based on the supplied “Tesla” theme. Then, I saved and restarted.

On first try, startup was stalled for a long time. So, after few minutes, I restarted in Verbose mode. Startup stalled for about 2 minutes at some point and then started moving again, until it completed in another few seconds. I restarted again in normal mode. This time, startup completed with only about 20 seconds delay. One startup after that – no problem.

2 - Next, in the new account, I created the second project – like the first one – but using the “Outline” theme (that’s the one that I normally use in my real project). Then, I saved and restarted. No problem!

The way I used the Outline theme this time was with no modifications whatsoever. Normally, I use it with extensive modifications – both in the theme’s options and by adding custom CSS. Also, normally, I use more stacks from different developers and “SiteMap Plus” from Yourhead instead of “RW Site Map”. So, this test was not fully functional, I must admit.

Any thoughts on that?

P.S. Now, here is another observation that adds a little twist to the whole story.

I noticed, that when I have a long delay in normal startup (several minutes – no patience for more waiting than that) and then I try to re-start in Verbose mode, there is an initial delay in the middle and then startup completes. After that, normal startup completes with no problem (or with very short delay). That has me stumped. It looks like the Verbose startup cleans some hurdles up, afterall…