Strata Theme - Links "above the fold" aren't clickable


(Dan) #1

I just switched to the Strata theme for my website in RW7.

I’m having an issue where all the links in the top few inches of the main container can’t be clicked. Every link “above the fold” isn’t clickable - whether it be in text, an image or an ad.

For example, at the link below the top Google Ad along with the top few in text links and the top half of the first big image in the main container can’t be clicked. All the pages are like this.
http://motorscooterguide.net/Honda/Elite80/Elite80.html

If I switch to another theme, this problem goes away. I just tried re-installing the theme, but it’s the same deal. From Googling this, it seems like the issue probably has something to do with the z-index and/or misplaced div tags, but I don’t know enough about this to figure it out. Can anyone help?


(Ben) #2

i have the same problem


(Ken) #3

Hi Dan
I don’t believe there is an RW or Theme fault. There are a couple of things I would suggest. Firstly clean out any pages on the browser you are using. Then go through the normal link process. It clearly works as you’ve been OK on most of your links. If the Preview in browser works ok, then you have probably not in sync with your host and your local preview.

Ideally you need to clean out the host of your entire site. When you’ve done this republish your entire site. If you haven’t got an ftp tool for the host ‘clean out’ just republish your entire site
Ken


(Dan) #4

Hi Ken,
This issue is the same whether I view the website in rapidweaver, preview it from Rapidweaver (in a browser), or export the website and upload it. So I think the problem is upstream of the host/ftp.

I tried re-stalling the theme but no change. I tried starting a new project, but the issue is still there. If I switch to another theme it is gone, so it seems to be a problem with the Strata theme.


(Dan) #5

Hey Ben,

I got it fixed by asking here:
https://stackoverflow.com/questions/46710014/unclickable-links-above-the-fold

To fix it, go into the theme contents package (themes -> right click Strata -> Show in Finder) and open the index.html file with a text editor like TextWrangler. Then delete the following line:

div id=“t-band-fx”></div

This should be line ~62 in the html file. It would probably be possible to fix this by editing the CSS for this element instead of deleting the element, but just deleting the one line in the html seems to do it.

This “t-band-fx” seems to simply be adding a transparent layer (“band”) over the top of the content, blocking the links.


(Nick Cates) #6

Can you send me a link to view this issue. Would love to fix this in the theme, and help out all Strata owners. Thanks Ben!