Stripe Checkout & Foundation 'Fatal error on line 163'


(Jason Bostick) #1

I am using Stripe Checkout (from Yuzool) in conjunction with Foundation to sell gift certificates and service packages for a salon. I have a test version up with a few mock items. When processing a payment, it seems to go through (and there is a log of it in the Stripe account, so it seems to work on that end) but when it redirects to the page, I get the following error:

Fatal error: Class ‘Stripe’ not found in /home/jbosti5/public_html/euphoriasalon.ca/store.php on line 163

Does anyone know what that would be? I’m using Foundation for this page. I don’t know if having it in Test mode (instead of Live mode) is the reason or if it is something else…

The site is https://euphoriasalon.ca/store.php You can try out a mock transaction using card number 4242 4242 4242 4242, any CVC, and any expiry date as long as it is in the future.

Any help would be great (as would any critique of the layout, by the way).

Edit: I should mention that I’ve tried with and without redirecting to a seperate page and had the same error.


(Joe Workman) #2

are you properly imposing the Stripe PHP libraries on that page? that error leads me to think that the Stripe libs are not loaded.


(Jason Bostick) #3

Not totally sure, Joe. This is my first time using Stripe. Do you mean the Secret/Publshable keys? That’s really the only thing I’ve added from Stripe’s end (as per Yuzool’s instructions).


(Michael Frankland) #4

Looks like you fixed this - great and nice store :smile:
https://euphoriasalon.ca/thank_you.php

Stripe Checkout Works well with Foundation Theme