Struggling to publish large RW file - any tips

I’m really struggling to publish large RW sites, especially ones with a lot of high quality images.

These are some of the problems I experience:

  1. Takes long to save the RW8 file to NAS
  2. After the save has been completed, some of the image files are missing in the RW8 file
  3. Publishing takes forever
  4. Once publishing has been completed some of the images are missing
  5. Sometimes I have to first publish to local folder and then ftp the site to the domain server - nothing else works
  6. I’ve tried different Connection speeds from 2-Slow to 6-Lightning Fast
  7. I’ve tried different modes: from Extended Passive to Active
  8. I’ve also tried to place the images in a Resources folder on the domain server and link to it via External Resources. It just give me an icon in the Resources folder, but when I click on it, nothing happens

This is not just for one particular site. It happens all the time. Like this site I’m working on now. It has 1748 files which need to be published. It stopped at 779. Last time that happened I had to publish to local folder and then ftp to the domain server.

PLEASE HELP! :cold_sweat:

Is there any one who can shed some light here?

I’m not sure what you mean by “high quality images”. I realize the images are probably very good … but the real issue is size. Overall one should be aiming for photos that are sized 300k or less. (This is a very general guideline, and lots of other factors can influence this, but it’s still a good rule of thumb.)

Bottom line: whenever I have a lot of media “stuff”: photos, audio, PDFs, etc. then I warehouse them. i.e. I upload them directly to a specified folder at my hosting account. Then I simply use the URL to those things to use in my RW project. As a result my projects don’t get overly big.

Having said all that it looks like the problem may not be related to the images (hard to know for sure). I’ve noticed RW having the problem you encountered if I’m in a place with a more iffy internet connection. How good is your wifi access?

Hi Mathew,

Thanks for the reply. I agree that the image size is probably not the problem. Internet connection is 100mb up and down, so not too bad. If I look at the amount of time RW takes to just save the project, I think my Mac is due for an upgrade. (Or am I looking for an excuse to get the latest i9? Not sure. :thinking:) However, your idea to link the images via url will definitely help in the meantime and I’m going to give that a shot. Helps with maintenance as well.

Thanks again.

Have you tried to save on your local hard drive?

The error “Operation was aborted by an application callback” is often because of missing resources.

So as long as you have missing resources you’re probably not going to be able to publish.

Thanks for your reply. Local drive save works, but that creates vulnerabilities in terms of redundancy, so we have a NAS for that. I have read the article on the FTP Publishing Issues, but none of the suggestions helped. I have to assume that it is a local issue, something to do with the resources we use. Either the internet connection or the hardware. Was just hoping it was a setting or procedure I overlooked. I also believe @Mathew 's suggestion to warehouse the images will help.
Thanks again.

Something else that bugs me is that when I try to look at the upload logs it says there aren’t any, even though I have switched it on??

Doesn’t it sound like you have answered your own question and your problem is between your computer and the NAS , I assume wireless? Have you tried a more reliable ethernet instead? If it is ethernet already, my apologies.
You need to change your mindset, why does a “local drive creates vulnerabilities”? At least why does it cause anymore than the NAS? If uploading the site from a local HD works, that’s your solution to uploading and your NAS is a secondary backup…

1 Like

I agree totally with Chuck(@curiouschuck).
RapidWeaver project files are actually a special kind of folder called a package. They are a bit more complex than a simple file.

Lots of people have been having problems saving projects to remote storage like Dropbox or OneDrive. You’re NAS is probably experiencing these same issues.

One work around that’s been working for others is to save the file locally and then zip the file and store that wherever you want for redundancy and Remote access.

1 Like

Well, yes, @curiouschuck from what was said here and reading articles, my question has been answered. I was hoping for a different solution, though. Like you say, the mindset needs to be different. I have to add that using iCloud for storage has proved to be more successful than the NAS. And that’s what we’ve been doing @teefers, zip the file and upload to NAS. So, thanks everyone for your help. Have a great day!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.