Third party stacks show up as regular folders


(Tyler Coleman) #1

Hey RW community! I have a dilemma. I recently purchased the Video Player stack by Will Woodgate. However, the stack simply downloads as a regular folder with contents and not as an installable stack file (lego brick). I’ve already tried basic trouble-shooting by re-downloading and installing both RapidWeaver and Stacks and restarting my computer to no avail.

I’ve already reached out to Will Woodgate who has apparently never heard of this problem and directed me to YourHead (maker of Stacks plugin). I reached out to YourHead 6 days ago and finally heard back and they essentially said, “Meh… you might have to trouble-shoot with Apple or RapidWeaver.” I’ve already tried dropping the raw stack folder into the RW Addons folder with moderate success. It works, but seems buggy and definitely seems like not a permanent solution. Even Will Woodgate was hesitant about that.

I’m running macOS High Sierra 10.13.6 on a brand new 27” iMac 5K, RapidWeaver 7.5.5 (18814), and Stacks 3.6.1 (4160).

If ANYONE has had this same issue, please let me know how you resolved it. Below is the screenshot of the stack that should be an installable lego brick, but is, in fact, a regular folder.


(Isaiah Carew) #2

Hi Tyler,

I left a more detailed response with quite a few more things to try. Sorry for the slow response to the support queue, I’m not quite back to full steam after being unwell recently. My wife helps out when I’m not able to work full time and when she gets a tough one like this… well… yeah… 6 days. That’s not our best work. I really do apologize. We’ll try hard to do better in the future.

Isaiah


(Isaiah Carew) #3

One more thing:

I noticed in your email (alluded to here) that after you tried just installing the stack manually that you were concerned it will not update correctly or will behave poorly.

I want to let you know that the Finder icon has no impact on those things. The screenshot that you’ve posted here looks like a stack in perfect working order except for the icon. All the contents look to be where they are supposed to be.

A stack that looks like that should behave inside RapidWeaver perfectly, update correctly, and publish normally.

The Finder icon is really just that: an icon in the Finder. When the Finder doesn’t update that icon we can try a handful of things to encourage the Finder, or look for obvious things that might be the matter (other error messages, misbehaving utilities, etc.), but while were trying to get to the bottom of that mystery it’s perfectly fine to install the stack manually and get to work with RapidWeaver – RapidWeaver and Stacks won’t know or care.

If the stack is misbehaving in other ways, like isn’t producing the correct HTML, or doesn’t show up inside of RapidWeaver, etc… then let me or Will Woodgate know the details and we can work from there.