Total CMS Problem - Inhalte werden nicht gesichert


(Jan Jentsch) #1

Moin,

ich möchte gerne auf meiner Seite total CMS einsetzen (Lizenz ist gekauft und auf meinedomain.tld registriert).
Auf einer Admin-Seite habe ich entsprechende Felder für die Inhalte definiert. Die Seite ist auf den Server veröffentlicht worden. Jetzt will ich über die Admin-Seite im Browser die Inhalte eingeben und sichern (so wie in den Videotutorials von Joe W.). Leider wird der Inhalt nicht gespeichert. Woran kann das liegen?
foundation und alle Stacks sind auf dem neuesten Stand.

Gruß,
Jan


(Michael M.) #2

Hast du mal die Zugriffsrechte des Ordners cms-data überprüft? Ich hatte das auch mal und musste erst die Zugriffstechte ändern bevor Inhalte gespeichert wurden


(Jan Jentsch) #3

der “total-cms”-Ordner und alle darin enthaltenen Ordner ist auf die Rechte 750 eingestellt. Sollte also ok sein.


(Michael M.) #4

Stell mal auf 777 und schau was passiert


(Jan Jentsch) #5

Hi Michael, ich habe es jetzt mit fremder Hilfe herausgefunden. Irgendwie scheint sich das System zu verschlucken, wenn Testseiten auf anderen Unterordnern derselben Domain liegen. Also habe ich eine eigene Subdomain für die Testseite erstellt und dort das RW CMS System eingerichtet. Jetzt klappt es auch.

Gruß
Jan


(Michael M.) #6

Das wundert mich. So bin ich schon mehrfach vorgegangen und hatte diese Probleme nicht. Ich habe in den Tiefen meines Webspace sogar ein Testverzeichnis, wo ich diverse Konstrukte (auch mit TotalCMS) ausprobiere - funktioniert alles. Dies obwohl das nur ein Verzeichnispfad und keine Subdomain ist

Vielleicht hängt es auch von den Spezifitäten des jeweiligen Hosters ab


(Jan Jentsch) #7

ja, ich weiß auch nicht genau, was da los ist. Habe noch eine andere Eigenheit bei der Benutzung von totalCMS gefunden. wenn ich mit dem Text Macro einen HeaderPro Stack referenziere, dann passiert erstmal nichts. Erst wenn ich einen totalCMS text Stack zusätzlich einbaue und hochlade, erscheint der im CMS gespeicherte Text in beiden Feldern. Dann kann ich den CMS text Stack löschen und alle weiteren Änderungen werden im HeaderPro Stack problemlos übernommen.
Scheint sich irgendwo ein Bug zu verstecken.

gruß
Jan


(Joe Workman) #8

Sie müssen einen CMS-Core-Stack auf der Seite haben, damit die Makros verarbeitet werden können. Der CMS Core Stack enthält auch die Total CMS-Anwendung, die auf Ihrem Server veröffentlicht werden muss, damit der CMS funktioniert.

Sie können den Debug-Stack auch verwenden, um Debug- und Server probleme mit dem CMS zu beheben.


(Jan Jentsch) #9

Admin Stack und Core Stack sind laut Tutorial Video-Reihe “Implementation Walk-Thru” installiert.