Trouble publishing updates

I have not yet tried to connect with a stand alone ftp. I am not very savvy with doing that. The tech at Little Oak suggested it as well. He was able to connect that way.

My settings have changed so many times it isn’t even funny. He had me also try He also has me use the IP address. In addition, he had me change my password assuming I had forgotten mine.This is how the settings are currently set. Is there any reason why I would have been able to upload the original page and it appears that I am uploading, but the page never changes. I have emptied the cache, checked on different computers etc.

according to the FAQ knowledge base on LittleOak the settings you have in your screenshot look correct.

It’s no problem to put a little time to you in a video call. If it helps you get login then that is fine.

using the details above, we know you had success where the server was just so delete the ftp. bit and try again leaving the path at /www

Using the current setup if you hit the test button, does that work?

If that works then that tells us that the password and username are working. If that doesn’t work then we have an issue with those credentials.

I always use Ip address if I can, it takes DNS lookup out of the picture, but with the ftp. (no https) at the beginning that should work.

When you get a good Test to work next, I’d clear out the path (MAKE IT BLANK) and hit the Browse button. You should get a file list back.

If you get that far post back here.

Well, if you are connecting okay(no error messages) and everything looks like it is uploading, then it probably is. It’s just not going to the right place on the server. That’s where the path comes to play.

Are you hosting just a single website on that account with little Oak?

I have hosted nothing there for sometime, so I remember little about their setup. Most host give you a different directory for additional domains

I did hit the test button and it works. I cleared the path and used browse. The screen shots below show what I see . I am only hosting one website on that account.

I cannot thank both of you enough for spending this much time trying to help me figure out this problem .

1 Like

From that screen choose the www folder, that should fill in the path for you.
Then try publishing.

1 Like

I had to choose primary to get to www which is what I did. I uploaded again and it showed it publishing, but when I check the page the old page is still there. I am thinking I am missing something which is causing this to keep happening. I have checked the page on my desktop and my changes are there and saved,

I heard back from Real Mac. They asked me to do the following:

  1. Go to RapidWeaver > Preferences > Publishing and make sure “Upload Logging” is enabled

  2. Now, try publishing / recreating the issue again

  3. Finally, go to Help > Copy Support Logs and paste this into a document, and send it over

I enable “upload logging” and when I went to paste the logs received this error message

Devmate is no longer supported as a product which makes that error a little difficult to get around.

I’ve tried to look to see where the logs might be stored but nothing jumps out at me.

Since it looks like you have published okay, I think that you aren’t publishing to the same directory that the domain is pointing at.

To check this you’re going to need to look at the files that you put on server.

I don’t remember for sure, but I don’t believe that Little Oak has a control panel file manager. And what little knowledge base that they have (I don’t think it’s been updated in years) doesn’t mention one.

I don’t have access to their control panel, but you can look and see if they have a File Manager. If they do you can use that.

If not it means it’s time for a stand-alone FTP app. Since we know that the login credentials work, it’s as easy as picking one and going for it.

Anyway, what you are looking for is to look at the directory that you just published in the primary/www/ directory and find the files that you just published. You should be able to check the dates on the files.

Not sure there’s a publishing issue anymore. You aren’t getting any errors when you publish, are you? The publishing seems to work (takes some time, you get a display showing stuff being published, etc), but nothing shows up right?

Seems more like the directory where you are publishing too isn’t the one that the server is pointing at.

@dan @aaron @tpbradley. @isaiah? What’s up with this devmate stuff stopping log files. It’s happened a few times to different people since the last round of updates.

Thank you for looking. I’m wondering what Real Mac is going to tell me to do.

Thank you. They do have a control panel. I have tried looking in the file manager and I’m not seeing anything current, but may not be looking carefully enough. One of the techs told me he didn’t see anything uploaded since Nov 17th which is the date this website was uploaded. It replaced the last one with no issue. It looks like the files are uploading on my screen, but no change on the web.

I think it’s time to get a standalone FTP app or a new hosting company.

Anyway, the file manager, what does it show? Do you see a directory called primary/www or just www?

See I think you’re at the root of the problem. The tech is looking at the directory that the domain (the Internet) is pointing to. The files are being published to a different directory.

Thanks for the info on this, we’re looking into the DevMate crash report issues as we speak and will push out an update soon.



I believe I found the files in the file manager. They are in a folder called ftp. These must be the ones I uploaded to respond to Real Mac

looking at you website and the address in the browser. The folder “styled-04” is the one that contains the data for the page that’s not updating.

What you could do in the ftp client is rename that folder to say “styled-04-old” and try another publish. That way you guarantee creating a new folder with new files with the correct webpage data.

Also the folder ftp is fine for the upload but it’s the wrong place as you know they have to be in the folder called www. Does that browser window give you the ability to move or copy all those files?

1 Like

There appears to be a way to move the pages. I did another change on a different page and that has also gone to the ftp folder. Is this Rapid Weaver’s error or Little Oak’s? I want to be sure that I am not moving pages every time I am uploading because they wind up in the wrong place.

Rapidweaver will publish to the path you specify. If you selected the wrong folder then that’s where it will publish. It’s also based on the root directory that the hosting company lands you on when you log in with the FTP credentials.

So after you selected the www Directory what does the path statement and other settings look like?

1 Like

It is Fixed! :smiley: I am about ready to do a happy dance here. Not quite sure how I fixed it, but page is now updated. Thank you both so much.


would you mind showing us a screenshot of the publish settings like you had at the beginning of this ticket?

Yes, your web page has updated.

These are the current settings which I believe were the same as what they were from in beginning. Not sure why things were going wrong.

1 Like