"Unable to publish"

Rapidweaver 8.7
Big Sur
Stacks 4.1.2

I’m trying to republish all and I’m getting about ⅓ the way through the upload when it stops with the “Unable to publish” error message, ‘couldn’t upload to your FTP server’…

I’ve tried Extended Passive and Passive, and reducing the number of connections to 4, 3 and even 1 - it still does the same.

I’ve enabled upload logging, but when I try to copy the support logs, I get an error saying “DevMate crash reporter is not enabled.” so can’t see the logs and can’t find anything in the Console logs…

I’ve also tried reverting back to Stacks 4.0.4, but still no devmate, and still not able to publish…


Have you checked with the hosting service?

@dan is aware of the ”devmate” problem and expects to have a fix shortly (to the log problem, not your publishing issue).

Have you tried publishing to a local folder? If that works then you know it’s not a problem with a particular page or content. You can also use a standalone FTP client like Transmit or FileZilla.

1 Like

Having the Couldn’t upload to your FTP server error too. Checked hosting service and can connect to the FTP service. Will wait for a patch as mentioned by teeters above.

I have the same experience. I worked around it by writing the pages locally and uploading it with my FTP client as suggested by Teefers

Tweaking all the publishing parameters made no difference - still got the dreaded ‘Operation was aborted by an application callback’ message. But I turned off verify file transfers in Preferences and all files then published successfully. RW - are there any hazards in turning off verification?

1 Like

My host was having an unrelated issue (error 421: too many logged in users) as a result of incorrect connections not being terminated… they said it wasn’t me… but anyway - I tried publishing locally and FTP’ing using Forklift and the files uploaded without any error, multiple times…

Unfortunately, something still appears to be broken somewhere, either in Foundation, Rapidweaver, or Total CMS, or Stacks… which I’ll try to get to the bottom of…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.