Unable to save a file


(Butternut Squash) #1

OK, I am now unable to save a file.

I am unable to “save as” with a different name to the same folder.

I am unable to “save as” with a different name to a different folder.

This is outrageous.




(Mark Sealey) #2

Into which folder are you trying to save?


(congrio frito) #3

Has happened to me a couple of times since RW 7 … I had 18GB left on a 250 GB HHDD which was apparently now enough for RW to do a safe. After complete restart of Mac OS and 35GB of free space, saving was not an issue no more :frowning:


(Butternut Squash) #4

@MarkSealey

The original folder was Pomelo16. Couldn’t save into that.

Made a new folder, Pomelo17. Couldn’t save into that either.

Couldn’t save onto the desktop.

@congrio

I have 1.5 TB free on my hard drive, a ton of space.


(Mark Sealey) #5

Several questions occur to me:

• in which folder hierarchy was ‘Pomelo16’; it was in your user hierarchy?
• do you have more than one user account on your computer?
• what happens when you start RW 7 (you have got 7.0.2, and you did follow the instructions to upgrade from previous versions, didn’t you?) and save an all but empty new Project with a simple name like ‘MySite’ onto the Desktop?
• what do you see immediately after this failure when you launch /Applications/Utilities/Console and, having selected ‘All Messages’ top left, filter by ‘RapidWeaver’ in the top right?
• are you adding the .rw extension by any chance; and there is definitely no such file already in the location in question?

After that, I can only wonder whether there may be something inside the Project itself that is causing the error.

If so, I suggest starting a new project and saving it (presumably successfully) as you add each Page Type. Hopefully you will come to one type of Page which causes the failure; that might be the key. Of course, put in dummy data for each of these pages - this is an elimination test.

Is this the only Project that behaves this way? Could you, for example, do either of these:

1 - duplicate the Project (Cmnd-D) in the filesystem and then try opening and saving it? What happens?
2 - create and then save another Project with one page and another name?

Good luck!


(Butternut Squash) #6

@MarkSealey

Thank you for your really fastidious analysis.

This is the scoop, though. I have been editing this file on a page by page basis, and have “saved” it, and “saved it as” hundreds of times without any problems. And then mysteriously, I was no longer able to save it. The page itself was not an issue, as, except for the images, it was identical to a multitude of others that I have saved successfully.

As further proof it was not the page itself, and the changes that I had made, I ported the most recent page over to a new file, and saved the new file. It worked.

I ended up having to quit Rapidweaver, and reopen the original problematic file, having lost my previous changes. I then ported the most recent page back into the original file from the temporary one I had created. I then saved it, and it worked.

So it wasn’t the latest page, or any inherent weirdness it may have had. It’s a Rapidweaver bug. And a really upsetting one, at that. If it were not a known issue, there would not be all those very specific error messages in the images I originally attached.


(Mark Sealey) #7

Butternut - glad you fixed it, after a fashion.

Please let us know what RM says; I know they’re overwhelmed atm with technical support questions. But they’re also equally keen to improve the product. Good luck :slight_smile:


(Matthew Long) #8

I wrote about my own experience with a similar file saving problem as a reply to another post (link below):

I am sure that there are multiple scenarios in which file saving seems to fall over in RW, but at least I was able to find a predictable workaround for my own specific case that allowed me to get on with work.


(Mark Sealey) #9

Matthew - I too have had bugs where ‘Publish’ to a local folder has repeatedly failed. Maybe because I’ve been, for instance, Creating a Folder from within RW, rather than the Finder etc.

I typically just save the file and relaunch.

But isn’t @Butternut’s actually failure to save the Project file itself?

Or are you saying they may be connected?


(Matthew Long) #10

To clarify Mark, my problem is only one of saving. I have never had an issue with publishing or exporting. My issue arises when I simply try to save and I get a “Something went wrong with Rapidweaver and it has to close” pop up. It tells me to save, but of course it can’t. Neither can it ‘save as’. So I have to quit without saving, then go the the process that I outlined in the other thread to delete the error log, then I am good to go again for about a week or so before the cycle repeats.


(Mark Sealey) #11

Matthew - Yes; I’d say this is definitely a case for RM support. Good luck!


(e.g.,) #12

Was this SAVE failure ever resolved?