Upgrade has gone bad


(Tom Terleski) #1

Is there someone who can help with an upgrade from 5.4 to 6.0 rapid weaver. I have a very large website and have not been able to bring it over to the new 6 version. I recently upgraded to 5.4.1 and now lost stacks.

What a mess. Im proficient in working with the software, but have not a clue why my upgrade has gone so bad.

Thanks


(Tom Terleski) #2

I have a working copy of 5.4 on my laptop where everything was created. For the life of me I have not been able to bring that over to my desktop machine. I’ve copied all the library files and everything I can think of to no avail.


(Brandon Scott Corlett) #3

Greetings @Turk123,

I’m sorry to hear you are experiencing issues upgrading your rapid Weaver version.

Would you be able to provide a bit more clarity by recapping the steps that you have taken to get to where you are now starting with your downloading of RW6?

This will help us understand where things might’ve gone wrong and the best steps to take from here.


(Brian LaPan) #4

Continuing the discussion from Upgrade has gone bad:


(Brandon Scott Corlett) #5

Good to know. I take it that means it was resolved.

Cheers

Update: or not…


(Tom Terleski) #6

Hello

Let’s start from the beginning.

The last version I have that works with my website is 5.3.1 I also have a theme called Qube from nimbble software.

All that works fine on my laptop. I’ve purchased lots of addons from Joe Workman. I hesitate to upgrade the laptop for fear of losing a working environment and I wanted to move things over to my iMac 27 anyway. I understand I need to get to 5.4.1 to save it for the form that 6.0 needs. I have 5.4.1 on the iMac, but it refuses to use stacks and it has a problem recognizing the tube theme properly.

Guess that’s enough to start.

Site:

www.cave-astrola.com


(Robert Ziebol 🖖🏼) #7

I would delete the RapidWeaver 5.4.1 on the iMac, redownload load it, get the Stacks Plugin, install that. Then instead of copying from the laptop, use order lookup pages from the developers to get your stacks. Joe’s page is here:
http://joeworkman.cartloom.com/lookup
If you do not have your invoice order, use the retrieve order history option.

Then reinstall all of you stacks this way. See if this works any better.


(Tom Terleski) #8

Thanks zeebe

I did all that. I then copied the entire content of the folder “rapidweaver” that was in the user library under application support. That brought over the changes and settings I made to the “Qube” theme. I lost the stacks again, but I reinstalled the joe workman materials and the main stacks object. It’s working!

So I have 5.4.1 working on the iMac. I will follow the instructions to upgrade to version 6 of rapid weaver.

I’ll let you know!


(Tom Terleski) #9

Well, I installed rapid weaver 6.4.1 and everything came over but the Qube theme. The weird thing is that if I “preview” the page is not using the theme or has no setting from before. If I click on the header, the entire page fixes itself and is correct. The problem is that it is not permanent. I clicked on the header and then saved it, but the changes are not saved.

Weird and confusing. I’ve contacted Nibblehost the creators of the theme, but they have not responded yet.

Anyone have any ideas?


(Tom Terleski) #10

In the page inspector it shows “page specific theme” as “Qube”. Under theme styles it says “theme default”. If I go to the finder from here (with the gear option / “reveal styles”) it has my Home page style that I brought over from 5.4.1. If I double click the page style is says successfully installed.


(Tom Terleski) #11

I mis-spoke. The clicking of the header is just taking me to the website home page. It has a link built in. Sorry.

If I try to install the theme used in 5.4.1 it says “There is a problem installing the theme. Please check that it is not corrupted.” So RW 6.4.1 is not using my settings at all. Only the default Qube settings.


(Brandon Scott Corlett) #12

Have you tried removing the theme from RW6 then reinstalling it from a fresh download?

Make sure when you reinstall it isn’t being installed to RW5.


(Tom Terleski) #13

Hi Brandon

I finally have gotten it to work. The problem seems to be that the theme did not come over to 6 properly. Nimblehost also referred to an issue that they said is a RW issue when this happens. I reloaded the theme by double clicking on the theme I modified and is stored in RW 5 and it said it installed in 6. It then worked and even the page themes showed up in the inspector.

I now have RW 6 up and running. I guess I’m not looking forward to RW version 7 : )

I will say, the RW software is very stable. I’m impressed with what I can do with it. Hopefully version 6 with continue being very solid.


(Brandon Scott Corlett) #14

:slight_smile: I’m glad to hear you are up and running.

RW6 has been a HUGE improvement over RW5.

I know that the upgrade this round was a little but of a chore and some people had an easier time than other. I think a big part of this was the fact that RW is now sandboxed.

The upgrade to RW7 should be much simpler and straight forward.

Time will tell. In the meantime enjoy RW6! :smiley: