Upgrade to 6 worth it?


(Michael Foster) #1

Hi

I created my website a while ago and was just looking at re-vamping it a bit and found out that there has been a major upgrade to the current 6 version (I’m still on 5). Should I upgrade? Will my site still work seamlessly? I am obviously not on top of this as my site is the only one I use the software for.


(Brad Halstead) #2

@mfoster.vt

It really depends on what plugins/stacks/Themes you are using…

At the very least you should upgrade to the latest version of RapidWeaver 5 (5.4.1), if your using YourHead stacks, update to his last v2 stacks plugin (2.7.1).

Then, check if there are any updates to the stacks you purchased if any, install as required

Then check for Theme updates if any, install as required

Doing this work will prep you should you wish to go to RW6 and Stacks 3.

Investigate the stacks (if any) that you are using on your site. Some dev’s have gone out of business, sold to other developers or only make stacks v 3 of their plugins. If there are no updates available then your site may/may not be ready for RW6 and Stacks 3. You might have to source a similar product if even possible. Log hound made some fantastic stuff apparently (I hadn’t had the chance to use any) but he just closed shop and is not selling his products anymore so that’s one stacks dev that you won’t be able to find replacement stacks for (I believe).

When upgrading to RW6, there is a specific set of steps that need to be observed for your projects from RW5 to work in 6. There was a link but it seems that the FAQ section is currently under re-write as I am unable to find the steps.

Fortunately, if you’ve followed to this point, then there is a 30 day trial you can use of RW6 so give it a test run and see if it suits you and if your site will work.

Brad


(Michael Foster) #3

Thanks Brad for that info. I just figured out some more things that I think are going to drive me crazy. I made the transition from iPhoto to Photos a while ago, but rarely use either program as I am a diehard Lightroom user. Well I realized that the photos on a few of my site pages are not there because it is looking for them in iPhoto. The files actually reside in Photos, but I can’t figure out if I can get to these files with the current version of RW that I have (5.4.1) I did a search on the forum and it seems that others have the same issue. Is there any way to get these photos out of Photos into my version of RW? I have looked at the iMedia browser and can find no way to get into the Photos library.


(Brad Halstead) #4

@mfoster.vt

iPhoto should still be accessible in OSX 10.11.3+ (You SHOULD have backed up your iPhoto library prior to upgrading to Photo’s)

Close RW
Start iPhoto
Wait for iPhoto to start after you select the library
Start RW
Does it work now?

Also, you can use Photo’s in RW 5.4.1, just make sure it is open prior to opening RapidWeaver (I just tested and works A-OK)

HTH
Brad


(Brad Halstead) #5

Found the update process far… it is here

Brad


(Jannis from inStacks Software) #6

It is also possible to use the Photos app inside Media Browser of RW6:


(Michael Foster) #7

Just tried re-starting RW with Photos open and it still is not in the menu of the Imedia browser. Will have to re-starting both this evening when I get home from work. I see that it Instacks opened it in what looks like a similar place in RW6. I’ll have to look at that update process to see if it looks like it would be worth the hassle. May have to export my files out of Photos to be able to use them. I really hate the way that Apple buries files in their architecture so that it is not possible to access them without cracking open the vaults they are stored in. It’s one of the reasons I switched to using Lightroom for all of my photography processing and storage.


(Jannis from inStacks Software) #8

I opened it with RW6. If it is not opening for you with RW5, it might just not do (different application API).


(Brad Halstead) #9

@mfoster.vt

It works if you’re using a page type that references images (Gallery, etc) but not a stacks nor styled page…

Brad


(Michael Foster) #10

Just tried restarting Photos, then RW and opening the iMedia browser in a photo gallery page. Still no Photos access. I checked again and realize that I have RW 5.4 not 5.4.1 I tried updating within RW, but got an error that said there was an error in retrieving update information and to try again later. Now how frustrating is that? I looked to see if there is a link to a 5.4.1 update, but couldn’t find one.


(Brad Halstead) #11

@mfoster.vt

RW 5.4.1 can be downloaded here

Hope that helps
Brad


(Michael Foster) #12

Just found 5.4.1 and installed it. Still no photos showing in the browser. Pretty frustrating.


(Brad Halstead) #13

@mfoster.vt

They won’t show up in the Media Browser, but they will show up in a gallery page no issue… here is a screenshot of Photo’s with RW 5.4.1 (Media Browser open) but all images available in Gallery type page.

Brad


(Michael Foster) #14

I think I must be dense as I just can’t see where to find the pics in Photos. On my RW album page the middle column shows a list of sources for photos that includes a folder called Photos, but I believe that is just accessing the photos in iPhoto. I actually have the photos I want to use in Photos in albums with an album for each web page. I cannot find any way to navigate to this folder in Photos. I find this more frustrating than I can say. I think I will just export the photos I want and import them into Lightroom (which library I CAN access easily in the iMedia browser and the files are not locked up where you can’t get to them. I get that Apple was trying to make things brainless for average folks taking pictures, but I have never liked any of their photo apps. This just seals the deal for me. I will never use Photos for anything anymore (I only exported files from iPhoto as support for it was going away and thought I was doing the right thing, but obviously I probably would have been better off never using Photos and exporting all my photos to Lightroom) I know this rant is OT, but RW is trying to deal with the Apple architecture and I think that is part of the problem here.


(Brad Halstead) #15

@mfoster.vt

I feel your pain… but it truly does work in RW 6.3.8 without issue, RW5 can be a little wonky for this and Photo’s app.

Personally, I have never used the feature prior to your asking :slight_smile: and I won’t again either. Like you, I prefer to export manually and then import as a warehoused image or a local resource. One less app running on my poor old mac-mini 2011 lol

Cheers
Brad