Uploading files to host - which ones?

Having a problem here, and I’m struggling to see where I‘m going wrong. :thinking:
Client has asked for a new ‘charity’ button, (support page) removed Virgin, added just giving + link, can see it in RW. And the new logo is in the resource folder

Have uploaded all the folders I think are required to update just that page (top 6)

Cleared cache/browsing history etc, tried access on a number of machines, can still see the old logo?

Can we get a url?

It’s kind of hard to say what might be happening. I’m assuming that the screenshot is the folder that you published locally on your Mac.

Sounds like you aren’t using Rapidweaver to publish?

did you try to upload everything?

What are you uploading with?

Are you sure the path that you are using is correct?

Hi Doug…
No the screen shot is off the hosting.
I save the files in RW 8.3 onto my mac, then upload via fetch 5.8.2.

Have a blog on there so only wanted to upload the files that where connected to the page I was updating, as I’m a little unsure if I do a fresh upload of the lot, I’m thinking it will replace my original blog sample over the clients recent uploads. Paths are correct yes. And fetch has been fine for years/still is with other sites?

Okay, what blog are you using that allows a client to upload posts on their own?

The built-in blog requires the RW project file, so I guess that you are using something else.

You must understand what files any 3rd party addons or you or others put on the server and know where on the server they are stored. Otherwise, you can get yourself into big problems, even bigger than your experiencing now.

Does your hosting company backup these files? If not are you backing them up? Have you tested recovery from these backups?

Anyway, it sounds like you missed something when you tried to identify what changed. RapidWeaver doesn’t delete anything on the server but will overwrite files with the same name. So depending on what blog you are using you may or may not be safe doing a republish of all files. That’s why it’s important to know what is stored where.

What exactly did you change? Was there any text on the page or just the logo? If not, could you make a minor change to some text (add extra punctuation or a letter) to see if the change to the HTML is changing? Did the logo (whatever you named it) actually end up in the resources folder on the host?

Before I did too much more, I’d back up what you have on the server to your Mac.

I don’t have fetch, but many of its competitors (like Transmit) offer a folder synchronization process that allows you to automatically keep a folder on your Mac synchronized with the publishing directory on the host. I’d suggest you look into this for future publishing.

That would be helpful.

Thanks for the big reply Doug. Site is in foundry and blog is alloy. (Its my 1st blog for a client) so yes I‘m a little nervous re what I update :slightly_smiling_face:

Hosting backs it up, and I‘ve made a copy, just incase. But not tested them… thats a good point! :roll_eyes:

I’ve a feeling having put up a sample blog, if I update everything, thats what I will end up with, ie: back to sq one. I’m thinking its just the folder ‘posts’ is the upload from the client. Does it effect anything else do you know? index for example?

Changed just one logo as above. Will have another look at it all with a fresh head.
URL is above… on the 4hr ago post.

Cheers Jon

Something to consider if published changes don’t immediately show up is whether your host is using something like CloudFlare, which could cause a delay in changes showing up.

That aside, I’d strongly advise you rethink the publish-local-and-FTP thing - it’s actually adding significant risk if you’re not completely sure of the file structure you’re working with.

Once you’ve got Alloy properly set up, per the detailed instructions & videos on Elixir’s website, you’ll be absolutely fine republishing direct through RW - assuming the Client is updating content through the Alloy Editor - RW won’t be touching the /posts, /embeds or /droplets folders when publishing.

Don’t, under any circumstances, put the Alloy control stack in a Partial (I learned that the hard way!).

Honestly, if you follow @Elixir’s instructions, Alloy is an absolute doddle - you can’t go wrong. I’m using it to deliver >99% of the content on a couple of my sites (not just blogs), and it’s completely stable - never had any issues with blog entries going “back to sq one”, even on a full republish.

Best,

Adam (not that one).

2 Likes

Is this what you are expecting?

That’s what I see at the URL above.

Btw, Alloy allows you to back up the content from within the editor.

Content Backups

In addition to creating and managing your content Alloy’s Editor also allows you to download a backup copy of your content at any time directly from the Utility Menu in the Editor. The backups are downloaded as a ZIP file that contains the Markdown data for the individual content types. This allows you to upload them manually to your server using your FTP server if you ever have the need to. It also ensures that your content is always yours!

Thanks for all the help. It looks like Adam Jackson may have been right, re it taking a while and perhaps now uploading to CloudFlare. Its updated! :+1: Once I get the time, I must look into dropping Fetch and backing up from within Alloy however. Cheers Jon

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.