Uploading websites with FTP using Cpanel

Hi there,
I am trying to help a friend with a website update. I am by no means professional, but have had experience with designing. There are some questions I have concerning upload, C panel, and also swaping between an already existing Wordpress website to a Rapidweaver one (My preferred Software). I think at the moment I may have something wrong with the upload settings, as it is not appearing online properly.
If anyone would be willing to talk me through a few things, I would be extremely grateful. I have tried emailing the hosts, but conversations are always brief, due to demand I suppose, although they were still helpful to the questions I asked.
Thanks in advance!

Hi @39Graphics,

Welcome. What questions did you have about publishing we can help with?

Hi @dang
Thanks for reaching out!
Firstly, when I uploaded the site the first time, my friend helped me reroute it away from the original url to an extended url (as the original url still had the Wordpress website), which worked fine, but one page did not upload.
I contacted my host, and they helped me to turn off the reroute, and delete the Wordpress files using Cpanel.
I then reuploaded the website, but still one page was missing, although now it could be found with just the original url.
Since then, I have tried different ways of uploading, but still cannot get the full site uploaded, and now the website has turned into a really basic “link form” (I am not sure what it is professionally called, but everything is a link, and photos are now squares with question marks in them).
On top of that, browsers still recognise it as a Wordpress file, (the favicon being the Wordpress “W”) and the links to the original Wordpress website show up when you search on your browser (I have also tried this on several computers)
That is a lot of information sorry, but these are the main problems.
Feel free to attack this message one step at a time.

Sounds like a lot going on.

Can you post a link to the site so we can look at it? And what is the “1 page” that is missing?


Don’t forget the “.au”, as there is another website that is faithbaptist.com without “.au”

Hey @dang
I was speaking with my friend, and we have actually figured it out together.
He had set up a few websites of the same ftp, and I was publishing with not enough permissions, (he only giving me the password for the exact website, so I could not access the “public_html” folder).
I created a new ftp client, and I uploaded and praise to the Lord the website is up!
Thanks again for helping with this project, this community is very helpful!

1 Like

Nice, happy to hear you got it sorted. :raised_hands: