URGENT: I Can No Longer Preview Any Page in RW7


(David Perk) #1

For some reason I can no longer preview any page on any website I created in RW 7.15
Please help my get this fixed. I am dead in the water.


#2

Check your hosts file. Do a google search… I had the exact same issue. My problem was at some point my Hosts file became corrupt. Things would not preview within Rapidweaver.

I wish I could be more helpful but I don’t remember the exact details.

Best of luck to you with this most frustrating problem.


(Mark Sealey) #3

The hosts file is typically at the root of /etc


(Isaiah Carew) #4

That’s a pretty wild answer to that question. I’m interested to know if that works. If not, can you provide some more info about what is happening when you try to preview? Errors? Crashes? Blank?

If you have not recently edited your hosts file, or don’t know what a hosts file is, then I’d probably look for other solutions first. But if you’re brave, here’s some more detail:

The hosts file generally holds extra DNS info. It’s not usually something that most users edit. And it’s unlikely to get corrupted on its own.

The /etc directory like many of the other UNIX-ish things is hidden. You can use the Finder to get there though.

  1. In the finder choose Go to Folder… from the Go menu.
  2. You can open the hosts file by dropping it onto TextEdit.
  3. A generic hosts file should look like this:

You should not edit it unless you feel comfortable with UNIX.

Isaiah


(Zeb Ernest) #5

I have suddenly developed the same issue. It effects not only preview but also edit to varying degrees. I have never before seen this behavior in any project. This is version 7.15. So, your in edit mode and switch to preview it’s a white page. Same thing in edit. Over the day I restarted my mac many times. I even launched the demo of Joey and replicated it there. So it’s not my project. Then I noticed a signal degradation in my internet. A few more tests revealed that indeed my internet was dropping for a few seconds then it got worse. So okay maybe that has something to do with it. Perhaps RW is phoning home or something. Tech from the isp coming to change out equipment outside in the morning. I will post more after my net is solid again. If it does continue it’s a bug. In 7.15


(Doug Bennett) #6

Some themes and many stacks may need internet access to get CDN (content delivery network) items like j-query. But most should not effect edit.


(David Perk) #7

I followed your suggestion and used Google to search for a terminal code and now everything is back to normal. Thanks so much!


(scott williams) #8

I am really courious as to what is going on here to cause this. @dan, @isaiah can someone educate me? Seems pretty weird to me.


(Isaiah Carew) #9

Perhaps RW is phoning home or something

Developing software is not always easy. Often to minimize distractions, I disconnect my computer from the internet completely.

All of my plugins work the same with or without a network connection. They do connect to the internet to check for new versions. If the internet is not available, they don’t check. It doesn’t limit functionality in any way.

I don’t know if RapidWeaver is the same – but it has always worked for me without an internet connection.

That said, there is content that requires CDN access (e.g. Stacks allows some stacks to use a Content Delivery Network for jQuery). And some themes use CDNs to deliver things like bootstrap.

If you lose your internet connection (or disable it with a mangled hosts file) then this sort of thing can upset some themes.

Some stacks even use CDNs to load some CSS for edit mode (although, if any devs are listening, I would discourage this – local files are much faster and Edit Mode needs to be fast). While this wouldn’t disable edit mode entirely, it could probably make it look different than it normally does.

One other thing that might be related: there was a major root certificate failure last week. It brought down very major CDNs including jQuery.com. Stacks doesn’t use this CDN (stacks uses no CDNs by default – only if you enable them) – but many 3rd party addons probably do use jQuery.com. Furthermore, it’s a very insidious problem: depending on the browser, the OS – you may see more or less blocking due to cross-site limits.


(Jan Fuellemann) #10

Can you please tell us what you did to solve it - so others can benefit? and set the thread to “solved”?

Thank you!


(Peter Danckwerts) #11

I’d love to know how the hosts file can get altered without the user’s knowledge. This has happened to me and caused me a lot of trouble.


(David Perk) #12

Started a while after the upgrade to Sierra OS. When I disabled Gatekeeper in terminal (Google for code) everything when back to normal. Seems like an easy fix and it’s held so far. Give that a try.


(David Perk) #13
  1. Login to Terminal
  2. Enter sudo spctl --master-enable
  3. Enter your password

That’s all it took for me

For more details here’s a link: http://osxdaily.com/2015/05/04/disable-gatekeeper-command-line-mac-osx/


(David Perk) #14

It stopped working again. This is a bug and its a NIGHTMARE!!! Please give some attention to this matter asap!!!


(Dean) #15

This has been an issue since the initial release.

the developer just kept quiet and hoped we would stop whining!

don’t blame a modified hosts file, the hosts file can be modified.

it’s just the develop can’t seem to get a solution.


(David Perk) #16

I may have discovered my issue with the preview problem. I run little snitch on my Mac and when I disabled it the preview started working again. I then went into the rules and deleted anything that was relative to rapid Weaver. Fired up little snitch and the preview continue to work.


(C Pony Vigil) #17

I too still have issue with viewing pages on RW7 download latest version and still can not view site…Help is needed


(David Perk) #18

If you are Using a little snitch or any app that blocks outbound calls disable it. I did that at everything started working as it should.


(C Pony Vigil) #19

I read the instructions, this is not the issue, I simply ca not see edit window or pages on site that is built. it downloaded fine and my settings in security does not have that option on macOS Sierra

not good lost allot of business in the past month…

might loose my business completely, have to find a new career in computers…


(C Pony Vigil) #20

Version 7.1.7 of RW7
macOS Sierra
Processor 2.7 GHz Intel Core i5
iMac