WeaverBox error when uploading


(Andy Moose Dude) #1

I’ve been trying to get Weaverbox to work and have the page built and all that. A couple small issues like text not showing in buttons (emailing with Greg from @barchard about that) but also am having issues with an error message when uploading a file.
I will upload a file and get the ‘sorry, an error occured’ message.


I’ve checked with my FTP app and the file is going to where it needs to go apparently but I keep getting this ‘sorry’ message and no notification of the file being uploaded.
I’ve thrown this at Greg but would like to put it up here as well for anyone who might be able to chime in.
Thanks,


(Mark Sealey) #2

Spaces in the filename???

Filename too long???


(Gregory Barchard) #3

Responded to your other ticket. Just open a ticket and I’ll take a look. The suggestions above aren’t bad.

-Greg


(Pedro Perdomo M.) #4

Just to be sure:

Do you have a “data” folder inside the folder of the WeaverBox page?
If so, be sure that permissions are set to 777

Best


(Andy Moose Dude) #5

tried a file titled ‘file.png’ and same error.


(Andy Moose Dude) #6

/filemanager/public_html/page4/data/

‘page4’ is the folder listed on the Weaverbox page where it says ‘folder’.


(Mark Sealey) #7

And you do have permissions (755) to each/all of:

filemanager
public_html
page4, and
data

?

If you created ‘page4’ and ‘data’ (I’m not familiar with Weaverbox), did you set their permissions to 755, that is, to execute and write as the folder’s owner?

A good troubleshooting routine would be to try uploading a file like the ‘file.png’ into each of those locations in turn, starting at your server root (viz ‘file manager’), remembering to delete each one on success, and see whether/where it fails and with which error in Transmit.


(Andy Moose Dude) #8

public_htmal is set to 750
page4 is 755
data is 777

per Weaverbox setup guide…

Creating the data directory

The data directory is the folder where all of the file uploads will be placed. When PHP is unable to create this directory, an error similar to Figure 1 is displayed.

To fix this you will have to FTP into your host, navigate to the same folder as the page’s php script lives, and create a data folder. For this exercise let’s assume the following:

The page exported was called page42.php
In your browser you would view this page by going to mysite.com/filemanager/page42.php.

Therefore you should:

Connect to your host via FTP.
Navigate to the filemanager/ folder. In this folder you will see a page42.php file and (typically) a files/ folder.
Now create a new folder and call it “data” (no quotes). Figure 2 shows a weaverFM page with a new data folder.

Setting Folder Permissions

Once you have created the data directory, you will need to set the folder permissions to allow PHP write access. To do this simply ‘Get Info’ on the folder, set the permissions to 777, and hit ‘Apply’. Figure 3 shows the Info window for the data folder in Figure 2.


(Mark Sealey) #9

Andy,

Greg will be able to help you out with the specific WeaverBox errors.

750 for public_html seems a little odd; is that consistent with what your host stipulates?

From the docs you paste, is the path correct where public_html (one of the commonest docroots for shared hosting like this, to be sure) supposed to be where it is in the directory tree in relation to filemanager… I don’t know how your host has things set up?

What I’m wondering is whether it should be something like public_html/page4; then a different tree - perhaps - public_html/failemanager/data?

Greg will be the best person to comment on how these paths should look, though. Good luck!


(Andy Moose Dude) #10

thanks @MarkSealey . Greg will probably give me a hand.


(Andy Moose Dude) #11

tried changing public_html to 777 and, when going to page in browser, got a ‘internal server error’. I changed it back to 750 and the page loads correctly.
Same original post problem but 777 for ‘public_html’ caused more problems.


(Pedro Perdomo M.) #12

My settings:

/public_html set to 755

/upload site set to 755

/weverbox page set to 755

/data set to 777

/public_html / upload /weavebox /data

Working as expected

Best


(Andy Moose Dude) #13

I changed my settings to match yours.
However I idon’t have an ’ /upload site’

still getting ‘sorry, …’ message.


(Pedro Perdomo M.) #14

Upload site and weaver box page are names I give to my RW project

you must use yours