Website appears empty

I have not used RW since some month. After updating i tried to build a new website.
Publishing was successful but when visiting the website nothing at all appears in the browser.

Did anybody face similar problems after updating stacks?

No. Probably has nothing to do with updates. Sounds more like a publishing settings issue.

You said this was a “new site”, so I’m guessing you’ve never published to this site before?

If you published and got no errors, then it’s more than likely the path is incorrect or you’re getting something from cache.

Thank you. Will compare path structure with my existing website.
But how I could avoid to get something out of a cash?

Clearing your browser’s cache before and in-between testing varies by browser.

There are also some browser extensions available for most that can make clearing cache more manageable.

Thank you. I assumed it is a RW cash. I know how to empty a cash

However it is definitively not a path problem.
I replaced the index.html by !Hallo World" html file and it is displayed properly.
So it must be a problem with the RW html file

Was the index.html file you replaced created by RW? Can you post a link to the site?

I working only with RW. Always with the most updated version.
www.fritz-es.de
When I open the index file with FileZilla I find the simple paragraph
which is sight now the only element of my website.
Means the content is there.

Sorry I missed your question. The file “Hallo World” html file is a file
someone of a forum sent me. It seems often used to test as it is simple text.

Once you publish something Rapidweaver would have no way to affect what is in your browser’s cache.

I see nothing with the link above, no Hello World page.

If you need to use Filezilla to see the Hello World page, then it’s not being published to the correct location.

You’ll need to give us more complete information to get help.

Start with some screenshots of the publishing settings from RW, and the name and link to the hosting company.

1 Like

Thank you for your support.
Sorry, but after having proved the right path by displaying successfully an other html file I deleted “Hallo World” again.

Attached:
a) a screenshot of the empty webpage.
b) a screenshot showing location of index.html
c) screenshot of the content of the website opened by FileZilla
d) screenshot of webpage on my laptop

Nothing on that page other than head and body tags.

As teefers says, almost certainly you are publishing to the wrong place on the server. What does your host say the publishing path should be?

1 Like

You haven’t answered these.

The screenshots you show don’t tell us much.
It looks like the Filezilla is pointing to at /? That’s unusual that a host doesn’t have a sub directory like htdocs, www, public_html, etc etc.

1 Like

Maybe the ‘home’ folder is where you need to upload to? But best to check your hosts info as @teefers has said.

I can not understand your focus on the wrong path.

When I replace the index.html by an other html file and this file is displayed correctely by www.fritz-es.de it is proved that RW exports to the right directory. I have again uploaded “hallo world” so you can verify it yourself. index.html and RW folders are on the same directory path. All is manage correctely and automatically by my server provider.

Do you agree or disagree?

1 year before I had the same problem with my nowadays running website. www.solar-b.de I do not know, but suddenly at that time it had worked properly and works up to today. (without changing the path)

If the content of the website would be empty according my understanding there is something wrong with the file.

However, by viewing my index.html (right now replaced by “hallo world”) FileZilla displayed the content i put on the website. (See my screenshot last time).

So I am really lost what to do.

With what? With what little information you have provided it’s impossible to tell what you’ve done.

I’m not going to get into a debate with you, I’m not the one that has the problem.

YOU STILL HAVE NOT ANSWERED THESE QUESTIONS

You’re the person who can’t figure out how to publish. You came here for help, but we can’t unless you are willing to have a dialog back and forth, including answering pretty simple questions.

Nothing in computers “suddenly” on their own starts to work. Something changed, might be the web server, the OS, the network, DNS, something you did, a setting or something else, but something changed.

@sb-webadmin As @teefers says. Attached is a screenshot of my settings (though I have blurred out some things). Without this information it’s hard to help you. Your hosting company is also important. E.g. hopefully you aren’t using GoDaddy. At any rate folks know about quirky hosting companies and may be able to provide some pointers.

The areas in red boxes are especially important, although the overall screenshot may provide additional hints in some cases to what’s gone adrift.

Dear all who helped me. Thank you vey much for your concern and support.

Yesterday my hosing company admitted a mistake by not activating the
Apache service. Now, without any further change the website works as it should.
It was not a RW problem at all.

Sorry, but me as a non IT guy I am depending on guidance of others if it goes
byond just using a software.

1 Like