Website won't publish - Does anyone know how to upload via Filezilla?


(Casel Melendy) #21

Hello Greg and Tom,

Thank you both so much for your help. Backing up the website to a folder on my computer labeled public_html and then uploading through FileZilla directly to the public_html folder on my server worked perfectly! My new website is now live. I can’t say how much I appreciate this…it has been weeks of work…I even created a new website from scratch trying to figure out how to publish my website (out of the blue I suddenly couldn’t through RW…I still don’t know why). The good news is that it is now working, I learned a lot, and I like my new website a lot better than my old one:) I truly appreciate that you gave your time and hard won wisdom to help me out. I’ll pay it forward or if you have a ‘donate’ button hidden away somewhere, let me know.

Best wishes,
Casel


(Casel Melendy) #22

Just a minor followup. I found that once my website (30 pages) was uploaded to my public_html folder via FileZilla, I’m able to upload/publish directly from RapidWeaver again, as long as it is a single page at a time. The timeout and publishing failure may have been tied to trying to load my ‘biggish’ website all at once. It’s still strange that this happened all of a sudden, and I’m not sure if it is a server or RW issue, but it is good to know I can publish directly from RW if I do it in small enough increments. Thank you again for all of your help.


(Greg Schneck) #23

RW should be able to handle your website with no problems. 30 pages is not large. I have a large site (1500 pages) broken down into separate projects but, still, some are hundreds of pages they will upload (Publish) fine.

What happens when you try to Publish the entire site? Error msg? Stalls? Exact info would help.


(Casel Melendy) #24

Hello Greg, Thank you for getting back to me about this. I have Rapidweaver 8.3 and I use Foundary 1.3.4.2, along with Alloy, Potion Pack and Thunder (latest versions). I created my website from scratch (herenowhealing.com) as I was using Foundation before and I was unable to publish (you hadn’t yet shown me how to use FileZilla…thank you so much for that). Even so, with the new Foundary software, and all the updates to the latest versions, I cannot publish directly from Rapidweaver. The only way I can do it is as you taught me, through FileZilla, unless I publish one single page at a time. Even then it doesn’t always work. The error messages that I receive are ‘Operation was aborted by an application callback…and it gives me the ftp for my website’ The other error message I receive is ‘Timeout was reached’ and it give my ftp again. Nothing I have been able to do has changed this. I spoke at length with my server, TSO Host and they say that publishing isn’t being blocked on their end. They are the ones that recommended FileZilla.

There is one thing that I notice. When I publish through FileZilla, to get my website fully published, the connection ‘times out’ numerous times and then the file transfer fails, I am disconnected from the server, and then reconnected again…then the upload continues. Is it possible that when publishing from Rapidweaver, when it times out, then I am disconnected and NOT reconnected again…thus can’t publish? If you have any thoughts on this it would be much appreciated.

Best wishes,
Casel


(Greg Schneck) #25

It would be a big help if you could post a screenshot of your publishing settings. CONCEAL the USERNAME AND PASSWORD.

Have you tried:

  • “Connections” set to “1- Slowest” (it’s still plenty fast)
  • Mode “Extended Passive”

(Casel Melendy) #26

Hello Greg,

I’ve attached a screen shot of my settings, taken a few days ago, so it says connection fast, but I’ve tried all the speed options from slowest to fastest. I hadn’t tried extended passive, so just marked all of my pages and resources as changed, set it to the slowest speed, and hit publish. It uploaded to 21 of 588 then said that it could upload to my ftp server. Earlier I tried the extended passive just to upload one page and it worked very slowly, but it did publish. The one page upload has remained my limit. I can’t think of anything else to do. I’ve confirmed with TSO Host that the setting are correct, and it always used to work.

Best wishes,
Casel


(Casel Melendy) #27

ps - I meant to type that it said that it ‘couldn’t’ upload to my ftp server


(Mathew Mitchell) #28

Based on a quick look at your screenshot here are some suggestions below. Please keep in mind that different hosting services can differ in the exact kind of info they want. So some of my suggestions may not be useful. Trial and error will be needed.

  1. Path: I’d suggest changing to “public_html/”. Notice the slash at the end, not the beginning.
  2. Server: I give my website address without the HTTP and some other things. So in your case it would be: herenowhealing.com
  3. Mode: Extended Passive. This might be the most important one to try.
  4. Backup Frequency: not important right now, but once you can publish it’s a bit crazy to NOT set at backup frequency. It can help you in a lot of jams. I’ve set it to “once a day”

I hope one, or some combo, of these suggestions helps.


(Greg Schneck) #29

Agree with Mathew’s path suggestion of /public_html

I’m not sure what website address is used for. I leave mine blank and my uploads always work fine.

Backups: Good idea but worry about that later as Mathew says. I do my own backup by doing a download of my entire website with ftp. My ftp app allows for syncing so when I do backups only the changes are transferred to my “backup” set. This gives me an exact “capture” of the server including log files and other files that are “outside” of RW.


(Doug Bennett) #30
  • You’re connection times out with FileZilla and you’re having to reconnect numerous times.

  • You’re able to publish one page at a time with RapidWeaver.

That would probably indicate that your login credentials are good. The hosting company recommended FileZilla it’s not normal to have to reconnect numerous times with FileZilla to publish a 30 page site. What does your hosting company say about that?

As for the path the easiest thing to do is to clear the path and hit the browse button and then select the public_html directory. RapidWeaver will figure out if it needs a slash and where to place it.

If you’re timing out or getting application call back errors but are able to connect but are actually able to publish it can be a network problem. That can be on your end but usually is at the host end.

You can rule out your own connection by downloading large files from a reliable source (like Apple) with your browser and if it doesn’t get you any errors then it’s probably fine.


(Casel Melendy) #31

Hello Doug, Greg and Matthew,

Thank you all for taking the time to help me with this. I am going to read through and try out your suggestions and I let you know how it goes.

Best wishes,
Casel


(Casel Melendy) #32

Hello everyone,

Thank you for your suggestions. I tried each of them and also spent an hour on the phone with TSOHost. The end result is that I can still only upload my website via FileZilla. There is something up as with the Foundary blog too as I can upload photos via the ‘cloud’ option, and it does go to my image-uploads file, but won’t appear on my blog post…even with copying and pasting onto blog post editor page. I am having to use links through Imgur instead. Wondering at this point whether I have to change my server. I appreciate all of you for taking the time to suggest possible solutions…this one just may not be fixable!

Best wishes,
Casel


(Doug Bennett) #33

Don’t know anything about the blog issue, when you use FileZilla are you still timing out?


(Casel Melendy) #34

I switched to SFTP and I was able to upload via FileZilla without timing out, but those credentials don’t appear to work from the Rapidweaver publishing settings


(Doug Bennett) #35

I use SFTP with RapidWeaver all the time. I Haven’t used regular ftp in years.

  • What do the settings look like in FileZilla?
  • what happens when you try SFTP in RapidWeaver?
  • does your host require anything special like port number with SFTP?

(Mathew Mitchell) #36

@Casel I don’t have the time personally to do this, but if you trust @teefers (and he’s willing) then I suggest zipping your project file, sending it to him, and let him do some tests. That would be a lot quicker.

It may well be there’s some funkiness with your hosting service. It wouldn’t be the first time. But before going down that route it’s very important to make sure there’s not something amiss in your own process.


(Doug Bennett) #37

If you like you can private message me with a link(Dropbox or similar) to a zipped project and I’ll have a look.


(Casel Melendy) #38

Hello Doug and Mathew,

Sorry I disappeared…it’s been one of those weeks. Thank you so much for being willing to look at my website Doug. I’ll do a backup of my folder and see if I can upload it to drop box. Your help is so appreciated.

Best wishes,
Casel


(Mathew Mitchell) #39

Please make sure the zip that folder before delivering. It makes the size of the transfer about 50% less. And it’s much easier for Doug and you to deal with.