Where's my theme gone?!?


(Steve) #1

Since upgrading to RW 7.1.4, one of my websites can no longer find its theme.

Sure enough, the Theme Library does not include the missing theme, but when I try to re-install the theme, I am told that the theme I am trying to install is the same version of the theme that is already installed!
After telling it to continue to install the theme and restarting, the theme is still missing from the theme library.

Can someone please tell me
(a) where my original theme has gone?
(b) why the installer thinks it still exists?
© where I should look for installed themes for 7.1.4?

I appear to have RW themes in several different locations:
/Users/Steve/Library/Application Support/RapidWeaver
/Users/Steve/Library/Application Support/RapidWeaver/Themes
/Users/Steve/Library/Containers/com.realmacsoftware.rapidweaver/Data/Library/Application Support/RapidWeaver

… All very messy if you ask me!

Please help!


(Doug Bennett) #2

I believe that user instaled themes in RW7 would be here:

/Users/steve/Library/Containers/com.realmacsoftware.rapidweaver/Data/Library/Application Support/RapidWeaver/Themes/


(Steve) #3

Hi Doug, yes - I have come to the conclusion that this is the new theme repository.
I solved my problem by recreating the theme from scratch using another name.
The whole process of installing themes seems to be very hit-or-miss with RW7…


(Keith Flanagan ) #4

I had to reinstall all of my themes, stacks and plugins from scratch when I updated to 7.1.4. It was a mess that I am still cleaning up. Luckily the items were still located in my iCloud Drive but I still needed to tell RW that they were all registered. Had to look at old emails for serial numbers for them. Long and tedious process to say the least.

It is unacceptable that this was not properly vetted before being sent out as a production release. This release didn’t even seem to be a beta based on the behavior.

We paid good money for software that functions. I am NOT a beta tester. Do not treat me as one.


(Steve) #5

I share your pain Keith! RW 7.1.4 has not been a good experience for us, has it? Themes are all over the place on my Mac, and I don’t know enough about how it all hangs together to feel confident in deleting the superfluous copies… Maybe someone from RealMac can help us with this?


(Doug Bennett) #6

Yes they did move add-ons in RW7 including themes. I think this was to support the new feature to store your add-ons in any folder you would like. You might want to check out the video that covers that.
http://rapidweavercommunity.com/tutorials/series/new-features-in-rapidweaver-7/episode/user-selectable-addons-folder


(Steve) #7

Thanks Doug - that was most useful - I have now moved all of my Addons to a Dropbox folder that I can control. Just need to tidy up the mess that is left now! Cheers, Steve


(Doug Bennett) #8

Glade it helped… Please keep in mind that if you “clean-up” the mess I don’t think you can go back to RW6. This may not be important to you but to others it might.