WP-Blog plugin help


(Garth Poon) #1

Does anyone know of good, step-by-step WP-Blog instructions? The developer has given some, and I followed them, but I couldn’t get it to work properly. If anyone knows of anything, that would be awesome! Thanks all!


(Chaka Zulu) #2

Hi Garth,
could you specify your problem?


(Garth Poon) #3

Hi Chaka, I just can’t get WP-Blog to import my Wordpress site properly.

Here is the Home page (built in RW): http://jellymarketinginc.com/test/
Here is the WP-Blog page: http://jellymarketinginc.com/test/blog/
Here is the Wordpress installation: http://jellymarketinginc.com/test/wordpress

I know others have had trouble with WP-Blog as well, so I was hoping someone who has experience with it could offer some advice.

I love Armadillo as a blogging platform, but Armadillo doesn’t have an import function that would allow me to import blog posts from Blogger. My client would like to use Wordpress as the backend for their blog.


(Peter Danckwerts) #4

Does anyone really want to look at old blog posts?


(Chaka Zulu) #5

Try http://jellymarketinginc.com/blog/wordpress/
In your directory place the wordpress folder in the blog folder and adjust the setup accordingly.


(Garth Poon) #6

Hi @peterdanckwerts, yes, our blog posts are help articles with tips and tricks for our clients. We’d like our clients to be able to access them.

@chaka Thanks for the suggestion…but it still did not work.

Here is the RW home page: http://jellymarketinginc.com/test/
This is the location of the WP-Blog page: http://jellymarketinginc.com/test/blog/
This is the Wordpress installation: http://jellymarketinginc.com/test/blog/wordpress

I’ve followed Nilrog’s instructions and it still won’t import properly. And I’ve sent him emails and haven’t received much support.

I googled and found this old thread: http://forums.realmacsoftware.com/discussion/47216/wp-blog/p2. It looks like other people have had a lot of trouble getting WP-Blog to work, mostly because the instructions aren’t very clear.


(Chaka Zulu) #7

I also had some problems to setup wp-blog and this was my solution to the problem:

Did you change the setting in wordpress to
Wordpress Address (URL) http://jellymarketinginc.com/blog/wordpress
Site Address (URL): http://jellymarketinginc.com/blog

when you tried my suggestion?

The new forum does not allow me to post more than 3 replies, so I answer your latest post here:

Hi Garth,
you need to use the wp-blog theme that comes with the plugin. If it doesn’t appear in Wordpress you have to install it as described in the user guide.


(Garth Poon) #8

Thanks for your help, Chaka.

I’ve removed the “/index.php” from the Site Address URL setting in Wordpress and the blog now appears on my WP-Blog page http://jellymarketinginc.com/test/blog/

…but the formatting is all messed up. Should I hide the Rapidweaver sidebar? Why is there a gray background for part of the page? And why has the font changed in the nav menu and main content area? (flip back and forth between http://jellymarketinginc.com/test/ and http://jellymarketinginc.com/test/blog/ to see the differences)

And does anyone know how to get the Wordpress widgets (archives, categories, tags, etc.) to appear in the sidebar?

Does WP-Blog work with any Rapidweaver theme? And am I supposed to change the Wordpress theme (right now, it is the default Twenty Fifteen theme)?


(Peter Danckwerts) #9

What I can’t understand is that your blog page seems to be loading the CSS for the Ruby theme and for Foundation. That could explain why itt doesn’t look right.


(Garth Poon) #10

Hi @chaka and @peterdanckwerts, I got it working! Thank you so much for your help!


(Martin Waring) #11

Wow - That looks really nice. Think I might give that a try myself.


(Garth Poon) #12

Hi @MartWaring, we replaced our old Rapidblog-powered blog with the new WP-Blog powered one: http://jellymarketing.com/blog/

So far, it’s working great!


(Peter Danckwerts) #13

That does look good.


(annette zito) #14

Hi - Garth it does look fabulous! I’ve been trying to get the wp-blog plugin to work all day in my quest to have my site and blog integrated in one place. I really need instructions for dummies! :slightly_smiling:

I’ve got the blog exported from wordpress.com to wordpress.org at my Godaddy hosting (where my site is). I haven’t been able to get it to work on my RW site - I only get a blank theme page (http://kitchannette.com/wordpress/), Any thoughts?


(Garth Poon) #15

Hi, I followed this PDF step by step (when I was having troubles, I was following the steps in the side panel of the WP-Blog plugin in Rapidweaver (here’s the link: https://docs.google.com/document/d/1M9uUHQbBTqIHdhkAoW36cHycqdFwMyWo6ivGxp6jp8Y/edit).

When I followed those steps, it worked! Hope it works for you as well. :slightly_smiling:


(annette zito) #16

Thanks a lot! I had followed both the plug-in directions in RW and the User Manual PDF to no success BUT I did something right after your message it’s working (no navigation yet - my site has it’s own navigation through using Blocks - will be redoing the whole site with a new theme so for now, the blog is not in the navigation) - http://kitchannette.com/blog/

I have yet to figure out how to get the widgets to work - do I need to activate the sidebar in the theme to activate the widgets?

And there’s no “subscribe” widget - is there a plug-in I should be using that will work?


(Garth Poon) #17

I’m not sure, but I’d guess that you need to have a sidebar in your theme in order to display widgets. I think WP should have a subscribe widget, but i’m not a WP expert.


(annette zito) #18

Thanks Garth. Activating the sidebar in the theme knocked the whole blog offline. Darn widgets! If it isn’t rendering them, it’s not doing it’s job! I can’t figure it out.


(Garth Poon) #19

Sorry, I wish I could be of more help. I don’t have any suggestions…other than to contact the developer.


(annette zito) #20

Thank you so much! I don’t know what I did but I got it online and widgets working. Still loads of work to do but at least I figured some of it out. Thanks so much for responding and helping!