Blocked by host


(Andy Heron) #1

Twice when previewing changes to my website before publishing, my host has blocked my IP address. He said that RapidWeaver is generating too many connections to the server, and was therefore blocked.

How do I resolve this isssue? Or do I need to find a host that supports RapidWeaver. I do have a very large website.

Any suggestions?


(Rob D) #2

I would try using a separate FTP app (Transmit, CyberDuck, Yummy, Fetch, etc.) to upload my locally exported folder in smaller chunks at a time. I realize that this is not an optimal solution.


(Mark Sealey) #3

Your host may well mean that in the process of uploading to the server, your ftp connection is exceeding a maximum which they set.

If this is the case, try reducing the number in the Connections dropdown in Settings > Publishing from where you have it now (maybe you have 4, 5 or even 6) to 2 or 3.

You would have to explain to your host what happened and have them unblock your IP address.


(Andy Heron) #4

No. This is not the case. They say that I am making too many connections when previewing within RapidWeaver. This is not a problem with ftp publishing.

Thanks for the idea.


(Joe Workman) #5

Does this happen with only certain stacks on the page?


(Andy Heron) #6

Hi Joe

I hate to say this - but I didn’t publish anything last night when I was block. I was using your Impact stack that I had just purchased.

Andy


(Andy Heron) #7

Hi Joe

I was using Impact stack in conjunction with TotalCMS.

Andy


(Don H) #8

Are you warehousing your images on the server or adding them to Impact directly?


(Andy Heron) #9

Hi Joe / Don H

I must say that TotalCMS is brilliant. A few days ago I complete the history page that will let other people in my chess club update this page - including basic SEO.

Don H - My Header images are warehoused. The ones using the Impact stack are imported from a TotalCMS gallery.

Thanks to you both for helping.

Andy


(Don H) #10

Can you find out how many requests they are getting before they start blocking?

I would guess that it’s part of their system to mitigate denial of service attacks, but I find it hard to believe that RW preview is requesting files often enough to trigger it. Either there’s a bug in RW/ a stack or they have a very low threshold.


(Andy Heron) #11

Hi Don H

I have requested this information.

Andy


(Andy Heron) #12

Hi Don H

I got the following reply:- As we can see from the logs, it was found that 243 connection block led.

I have asked for clarification.

From cPanel I have the following information:-

Entry Processes

0 / 30 (0%)
Physical Memory Usage

0 bytes / 2 GB (0%)
IOPS

0 / 1,024 (0%)
I/O Usage

0 bytes/s / 10 MB/s (0%)
Number Of Processes

0 / 150 (0%)

Are the Entry Processes and Number of Processes too low in your opinion?

All the best

Andy


(Andy Heron) #13

Hi Don H

I have been informed that there were 243 simultaneous connections.

All the best

Andy


(Don H) #14

I don’t know enough server hosting to say one way or the other. They don’t seem particularly low.

243 simultaneous connections does surprise me and seem high. Has it happened again? If not, I wouldn’t worry about it. If it does happen again/regularly, I’d try to narrow down which stacks are causing it.


(Joe Workman) #15

Do you have 243 Total CMS elements on a single page?


(Andy Heron) #16

Hi Joe

Definitely not. I think I have 10 at the most.

The page I was playing about with is:-

glasgowpolychess.club/history/index.php

I am off to bed as it is ten minutes past midnight here. I will again look at RapidWeaver and see if there are any more stacks that I can disable tomorrow.


(Gregory Barchard) #17

Hi Andy

This sounds like connections are being opened from your computer but not closed/cleaned up when done. I have seen this with rw7, but nothing in recent memory with rw8. Switch to sftp instead of ftp if your host supports it. See if that helps. Your host may be able to provide you with some additional details about the connections. They should be able to search the logs for your Ip and may be able to classify them as ftp, mail, etc.

Hope that helps.

Your top dog,
Greg


(Gregory Barchard) #18

Nah this wouldn’t be totalcms related. :wink: I’m not involved as the host but have seen this before. Switching to sftp will most likely resolve or greatly improve this. :slight_smile:

Greg


(Andy Heron) #19

Hi Greg

My connection with my host uses ftps. I am using the latest rw8 (not a beta). I do not use mail, etc from the account where I use RapidWeaver. I will later see if there are any more stacks, themes that I can disable. Thanks for the suggestions.

All the best
Andy


(Joe Workman) #20

@barchard this could make an interesting podcast episode… FTP vs FTPS vs SFTP

My personal preference is SFTP. If I see a host that does not support SFTP, my view of them is a step above :poop:. Ok maybe that is a bit harsh on :poop:

LOL