Crash on SiteMap page


(jol yates) #1

Crash on SiteMap page RW8 - any ideas anyone Bueller ?


(Isaiah Carew) #2

With so little info there’s probably not much help the forum can provide other than generic help like: try rebooting. :stuck_out_tongue_closed_eyes:

With a repeating crash of a specific page your best bet may be to send the project to RW support for specific assistance. Software should never crash, so it’s likely a bug that will need to be carefully worked around until it gets fixed.

The forum can provide some insight too – but you should probably provide as much info about the situation as you can. Here’s a few things you might have:

  • The version of macOS you’re using.
  • Do you have any addons installed? Which? What versions?
  • Does this crash happen every time? Sometimes? Or just the one time?
  • Does the problem occur just when publishing a specific file?
  • Does the system offer a crash report afterwards? If so, you can post the first 50 lines or so of the file here to the forum – or send in an email to RW support.

By the way there is a similar 3rd party add-on called SiteMap Plus. If you’re using it, that’s good info to share too.


(John Scrip / MASSIVE Mastering LLC) #3

If absolutely nothing else, thanks for the tip. My site was crashing on export. Marked the site map “unchanged” and up she goes.


(jol yates) #4

Hi Isaiah

It seems you own what was Loghound’s SiteMap

I tried to change to the inbuilt RW SiteMap tool a couple of years ago - but far fewer pages showed up in Webmaster Tools as being indexed or submitted for indexing. Why this would be - I don’t know. So I have stuck with your sitemap tool for now.

[Not sure if others feel the same but - submitting and indexing to Google is hitty-missy and feels thoroughly unsatisfactory, perhaps even arbitrary to me. Note - I also submit manually a second ‘images_sitemap.xml’ generated externally and find this gets indexed readily]

Mac version is Mojave b7
Addons - yes - I have Stacks, RapidCart Pro and weaverpix (which has just stopped working)
Yes - crash happens every time I preview sitemap page or try to publish it

  • on any site file I try
    There is no crash report per-se

What’s worse now is that RW8 ‘cleverly’ tries to open the same damn file again - on the same page where it crashed - previewing the same sitemap - Now I cannot do anything with RW8 … Just watch it loop and crash : )

Ideas welcome !

JBob


(jol yates) #5

Even if I try to open a different file - or no file at all - RW8 will cleverly load up the file that crashes at the point at which it crashes … and crashes it : (

Shouldn’t all files start up in non-preview mode to avoid such issues ?


(jol yates) #6

Anyone know if I can delete prefs or something to get RW8 starting up without automatically opening a damn file (in kamikaze sitemap preview mode?)


(Isaiah Carew) #7

Much easier:

  • Hold down the Option key while you launch RapidWeaver. This will allow you to change what loads.
  • Disable plugins.
  • Switch to a different page. Click to Edit mode. And close the file.
  • Now you should be able to relaunch normally again.

About the crash:

What versions of SiteMap and other plugins do you have installed?

Can you send me the project file? I suspect some setting/content in SiteMap+ is triggering this. It would be very helpful to have the file.

Just compress it (right click in the finder and choose compress) and share the zip file on Dropbox (or similar sharing service). You can send me the link here or to http://yourhead.com/support Thx! :smiley:

Thanks


(jol yates) #8

Thank you so much Isaiah - I got RW8 going again !!!


(Isaiah Carew) #9

Great!

Can you tell me what version of SiteMap you’re using?
And when you have time, can you send a copy of that project file?

If I can make the crash happen here in our debugger I can get it fixed.

Thanks


(jol yates) #10

No I can’t coz it doesn’t tell me ; )

Will try to get you a file tonight - though I’m sure you’re going to tell me my version is too old : )


(jol yates) #11

Hi Isaiah

I have sent you a link to d/l file from Dropbox

Hope you can find the crash

Best, Jol


(Greg Schneck) #12

@isaiah As info, SiteMap is working fine for me in v8 but admittedly my testing so far is limited. Displays fine and publishes fine. I’m using it to create Alphabetical Lists.


(Marian Wosnitza) #13

Exactly right. My RW8 site refused to publish until I changed site map to “unchanged”.
Ihre must be a problem with site map.
Does anybody know if there is an update?


(Marian Wosnitza) #14

Now I installed SiteMap_3.0.0_1117, latest version from Yourhead.com
Same thing: RW8 CRASHES in the moment you click PUBLISH.


(John Scrip / MASSIVE Mastering LLC) #15

I’m using (Loghound?) SiteMap Plus V302 (Build 309 / 302)

Even trying to preview (or “simulate”) crashes.

[EDIT] And I just found out that Loghound is no more. So I guess - uh - I guess I’ll wait to see if RM/RW finds a fix or I’ll just have to go another route.


(Doug Bennett) #16

Sitemap plus is now supported by YourHead @isaiah.


(Isaiah Carew) #17

We’ve identified a crash in SiteMap thanks to @jbob, but it’s quite a bit more complex than I would have hoped. I will be working on it over the weekend and hope to have more news about this soon.

As some Sitemaps pages appear to be immune to this, I’m hoping there may be a workaround. If there is I’ll post it here when I find it. Otherwise look for a fix sometime next week. Sorry it can’t be quicker, I maintain a few LogHound plugins. Although I’ve made some improvements to these, with the exception of PlusKit (which had a large upgrade), these plugins are foreign code so I’m moving a bit more slowly than usual.

In the meantime I’d recommend removing the SiteMap plugin from your plugins folder. The page will not be publishable obviously, but you can otherwise continue to get work done.

Isaiah


(jol yates) #18

Well done Isaiah - half the battle!

Perhaps after - can you think about an optional ‘images_sitemap.xml’
(My site is mainly visual that’s why I ask - I’ve done it outside of RW and it seems to submit and index successfully as a second sitemap in Search Console)


(Isaiah Carew) #19

So… a crazy thing just happened. I updated to the latest RapidWeaver – v8.0.3 which came out this morning. It seems to have “fixed” the SiteMap crashing project @jbob sent me.

This was very confusing as I was in the process of dismantling some parts of my SiteMap code and couldn’t figure out what I had done to make the problem go away.

So I decided to start from scratch, re-unzip the crashing project, re-installing the released version of SiteMap… and… no crashing. :rofl::crazy_face::upside_down_face:

So… I think this “sitemap bug” may have been a bug in the RW exporter? And it was repaired in RW v8.0.3? But I can’t be certain – since it’s vanished without a trace!

@jbob – after updating to RW v8.0.3, do you still have a crash when you attempt to preview your SiteMap page? anyone else?


(Greg Schneck) #20

@isaiah
As stated above my Sitemap Plus has been working fine in RW7 and RW8… all versions. I use the Alphabetical feature to create Alphabetical Lists.

However, please see this post and my analysis of a strange behavior with Preview in RW8 where you asked for sample projects of preview problems: