Multiple issues with RW 8.1.3


(Julian) #1

Hello all,
I did a silly thing. I updated (from v8.0.3 to v8.1.3) and now… Why do I keep doing this?
Ok sillyness asside the problems are multiple:

  1. Cannot save changes. When prompted to save changes RW seemingly hangs for a while then I get “The document [project name cannot be saved” dialog with a long list of issues.
  2. v8.1.3 does not respect the size of the thumbnails in a photo album page. No mater where i put the slider the published thumbnails are all LARGE.
  3. I tried to going back the known working v.8.0.3 and after several crashes a dialog popped up stating that the document was created with RW v8.1 and cannot be opened. So I either have revert to a previous backup of the site and recreate dozens of posts or…
  4. A little thing but one that wastes a ton of time. When I drag and drop a list of files, with sequential numbering as names, into a file sharing page always the first file, lowest number, is placed at the end of the list. example:
    pic_1.jpg
    pic_2.jpg
    pic_3.jpg
    pic_4.jpg
    are dragged into the File Sharing page I get…
    pic_2.jpg
    pic_3.jpg
    pic_4.jpg
    pic_1.jpg
    This has happened in every version of RW since I started using it in v5
    I am commercial photographer and use the site to deliver content to my clients. I know this sounds like a little thing but with hundreds of pages with thousands of images this issue eats up a tone of time collectively.
    Thank you Dan and the whole team for your constant help in keeping RW being so awesome!

(Jan Fuellemann) #2

Tagging @tpbradley


(Thomas Roegner) #3

Hi all,
quite happy with 8.1.3 - stable and none of the problems mentioned above.
Just 2 points:

  1. When trying to add photos via resources RW says “Can’t find photos” (screenshot attached) and
    • but this is minimal - when naming a partial and hitting “back” the partial still has its “genuine number”. Only after double clicking the partial again and going back it shows its given name.
      Any idea/chance to get this right @tpbradley @isaiah ?
      Thanks a lot in advance for assistance,
      Tom


(Rob D) #4

This is happening also in 8.0.3.


(Tom Bradley) #5

Hey @Julian,

There’s quite a few different things going on in this thread - I’ll try to address them all.

  1. Cannot save changes: Can you email your project to support@realmacsoftware.com with a subject of “FAO: Tom #3023”. Also, can you include the error messages you’re seeing? Try to copy/paste them or take a screenshot.

  2. Photo Album Thumbnail Size: I’ve reproduced this and logged it, thanks.

  3. Can’t downgrade: I’m afraid so - it’s due to document file changes. We’ll try and get the 8.1.3 bugs fixed up ASAP!

  4. File Sharing order: Solved in the next 8.1.4 beta

@capetom,

  1. Can’t find photos: What version of macOS are you using? Do all your images appear when you launch the Photos app?

  2. Stacks Partials: I can’t answer this, pinging @isaiah


(Isaiah Carew) #6

Hi @capetom ,

You’re right. We introduced this bug in a recent update when improving the speed of partials – it was a sort of ugly side effect.

It is, however, just cosmetic (meaning that the data underneath is correct) – the display just ising being refreshed. For this reason we’re not rushing an update out to fix that. We’ll just try to catch in on the next bug-fix.

BTW: we keep an open bug tracker. We like the transparency.

If you’re interested in this sort of thing you can follow our progress on this issue if and get even notified when it gets fixed. We’re tracking a related bug here: https://gitlab.com/yourhead/stacks/issues/181 It’s slightly different but when we fix one we’ll fix the other too.

You need to have a gitlab account to see that URL – but the account is free and open to anyone.


(Thomas Roegner) #7

Thanks @tpbradley for taking this up.

  1. Mojave 10.14.2
  2. All photos are there (at least the last ones synchronized/uploaded to icloud)

(screenshots attached)

Thanks @isaiah - I know, it is more cosmetic, just wanted to throw it in in case it was overlooked - no rush (waiting also for Stacks 4 … :grinning:)09 54


(Isaiah Carew) #8

@capetom - thanks for reporting. always appreciated. but @joeworkman reported that one last week or the week before. he’s pretty on top of these things. :face_with_monocle:

did you seem my blog post this morning about Stacks 4:

not much info, but some little peaks into what we’re working on this week.


(Thomas Roegner) #9

Yep. Just read your blog post. Interesting that the devs (=you) have to fiddle with all these small and detailled things like the appearence of buttons and symbols “only” because Apple decided to have a dark mode (which I don’t use at all, never was a friend of dark UIs not even in photoshop or similar programs). And takes you days to get it how you want it. Kinda like us RW users trying to build a site which looks perfect – in a much more coarse way…


(Tim Jessell) #10

Yes… updating to 8.1.3 was a disaster… wanted to relink all these jpeg files… I complied… then errors loading page - site never loaded, could not a view single page. Thank God for time machine and downgrade version. Again what a disaster. Not happy…


(Tom Bradley) #11

@capetom Thanks! Could you do a few more things for me…

  1. Take a screenshot of the General preferences in the Photos app
  2. Send me RapidWeaver’s logs
    • Make sure RapidWeaver is closed
    • Launch RapidWeaver
    • Create a new project
    • Open the Site Resources window
    • Choose Photos
    • Wait for ~30 seconds or so
    • Choose “Copy Support Logs” from RapidWeaver’s Help menu
    • Email the file to support@realmacsoftware.com with a subject of “FAO: Tom #3025

(Thomas Roegner) #12

Thanks a mil, @tpbradley ,

sent the mail with screenshots and log.


(Julian) #13

Hello and thank you tom.

As to #1. I sent the screen shot in a support request email and I think you already saw it. Let me know if you would still like me to sent the project file. I am on a location shoot and will not be back into the studio until Monday.

As to #2 Great thank you.

As to #3. Ok I’ll hang on. Thanks.

As to #4. YaY! FABULOUS! Thank you muchly.

ju


(Tom Bradley) #14

There’s a new beta up that fixes a bunch of things!

@Julian @capetom Could you give it a try and let me know if you’re still having problems.


(Julian) #15

Thank you so much for grinding on this. I’ll be back in the office Monday and will fire it up and see where the smoke leaks out. :smiley:
And will let you know.
Again thank you so so much.
julian


(Johnnie Byrd) #16

I’m getting tired, and gun-shy, of hitting the update button and then spending hours getting things back the way they were (Time Machine). Thinking about WordPress …


(Julian) #17

Tom, you nailed it!
I just tested 20641b and all the issues I was having seem to be fixed. To it…

#1. Saves are now working -and working faster than ever before!
#2. Photo Album thumbnail size is now working as it should.
#3. Non-issue. Just a lack of documentation.
#4. The odd quirk of placing first file in a sequence at the end has been fixed. YaY!

As far as I can tell this version fixes all the bugs introduced in previous versions and also addresses a minor issue that I’ve had for years.

Thank you so much Tom and the whole development team. You ROCK!!!


(Tom Bradley) #18

Thanks for letting me know @Julian, that’s great to hear!


(Gavin Tanner) #19

Hi Tom
installed 8.1.3 and since then have lost all links to resource files. Using Rapidcart pro
Any help would be appreciated


(Tom Bradley) #20

Hey @gavtanner, would you be able to send your project file to support@realmacsoftware.com with a subject of “FAO: Tom #3029”.

Also, have you tried the 8.1.4 beta to see if it solves the problem?

Cheers