N00b cannot publish


I am a total RW beginner who is proud to have designed and built a RW/Stacks website. Now, to live test it, I would like to publish it. To do so I have gone through all the motions but I am not succeeding.

See the attached screenshots please, with the second one showing that the ‘test’ thinks all is in order. However, the destination url does not show my RW website.

Any tips?



What happens when you try to publish?
Do you get any error messages?
Who’s your hosting company?

The test button only really test the login credentials(server, username and password). If when you push the publish button you don’t get any errors the path could be wrong.

I also noticed that the website address on the publishing settings
It doesn’t seem to be registered.

… and ‘public-html’ (hyphen) is more common than ‘public_html’ (underbar); have you checked that?

Many users also find that the ‘6 - Lightning Fast!’ Connection Speed setting can cause hosts to reject too many incoming (S)FTP threads. You may want to try ‘3’ and see if that improves things.

Thank you for your help. I registered the site yesterday, so it should be OK. See the screenshot please for what happens after I hit the publish button…

Thank you for your advice, which I will follow immediately and see what happens…

Thanks again Mark, but both did not help. The hyphen/underscore change got me a “cannot contact the server” type message, while the slower settings I tried got this…

Also, are you using FTPS or FTP?
If the test button still works. Clear out the path and hit the browse button. You should be able to select the path; it will put in the appropriate / as needed.

Hosting company is Namecheap.

I wil try that clearing of the path idea.

The DNS hasn’t been set up or propagated yet.

Excuse my ignorance please, but what is ‘DNS’?

I cleared the path and hot the brows button, but then I need to select a publishing location. What to select…?..

Domain Name Server. It translates the domain name to an IP address.

If you registered the domain with NameCheap and are hosting there, it can take a few hours (24 or more sometimes) for this information to propagate to all the DN Servers on the internet.

Select public_html

Thanks again Doug. Unfortunately, that did not help. Still getting this…

I guess is that propagation issue you raised. I will try again tomorrow.

No Ithe propagation would affect getting to the website after it’s uploaded, not uploading it.

I notice that the screenshot (the first one) you had FTPS selected?

I took a quick look at the host help area: https://www.namecheap.com/support/knowledgebase/article.aspx/188/205/how-to-access-an-account-via-ftp

They use something called FTPES, SFTP or regular FTP. The error message you are getting is trying to use FTP-TLS ( Transport Layer Security). I think there might be an issue with using FTPS.

You might try using Regular FTP just to test everything out. I wouldn’t recommend it for a long term solution for security reasons.

I personally use SFTP for everything. I find FTPS to have a bit more difficulty (especially behind firewalls). It looks like to use SFTP with NameCheap you use the CPanel Login credentials and port 21098. To add a port to RapidWeaver simply add a :21098 so the end of the server name.

1 Like

I tried with regular FTP. Same result.

Purely an aside, Jim; if I may: Namecheap has a horrendous reputation (but one of many sources here) for encouraging organized crime (spammers).

If you’ve not already formed a relationship with Namecheap from which you’re unable to back out, may I be so bold as to suggest you find a more socially-responsible host?

I’d try changing the mode The Unknown PASV (Passive) reply. Try active or Passive.

Thank you for pointing that out Mark. I appreciate it. I do have a series of domain names registered and now one site hosted through with them. Any suggestions for a better but equally economical alternative?