Plus Kit 4 Not Working

Does anyone know why Plus Kit 4 may not be working in RW8? I’ve tried deleting it and downloading a fresh copy but I keep getting the same error message: Pluskit Couldn’t obtain principal class. Realmac says the problem is on YourHead’s end but I’ve reached out twice (my first contact with them was 15 days ago) and they are not responding. Can anyone help?

Tagging @isaiah

I’m guessing it might be because you’re running RapidWeaver on an M1 Mac, all plugins need to be updated to work with Apple Silicon.

More details can be found here:

Ah yes I just updated to a new Mac with M1 and then I updated the plug in. That being said, when I purchased Plus Kit 4, there was no warning that it would not work on M1. Stacks works so I had no reason to think Plus Kit 4 would be any different. This developer took the payment, has yet to respond to both support tickets and didn’t post a warning at point of sale. I didn’t invest in a new Mac to run the programs on Rosetta at lower quality. How can I get a resolution here? Can anyone reach the developer to find out when/if this app will be comparable with M1 or if I can get a refund?

We can tag him here (@isaiah), but that’s been done.

He hasn’t been on the form since June 8th.

He has a slack Channel:

Slack Channel Info

Slack channel (sign-up): http://slack.yourhead.com
Slack channel (sign-in): https://yourhead.slack.com
But it doesn’t look like he’s posted there for a while either.

It looks like from this post that the universal build of the old Loghound plugins (Pluskit is one) planned to have been done by now (End of May).

Has anyone heard anything from Isaiah lately? @realmac @tpbradley @joeworkman @Elixir @instacks

1 Like

Unfortunately I have not heard from him in quite some time (months maybe?). I’ve messaged him in the developer Slack group, emailed him, tagged him here on the forums and more. All with no response.

The most I’ve heard back is from a post on Twitter where I replied to something he tweeted about. Other than that I haven’t talked with him. I have begun to worry about him in the past few weeks and emailed to check in on him.

Hope he’s doing ok.

1 Like

I had a brief conversation with him recently. He was out of the office for a few weeks but should be back this week.

4 Likes

Recently bought a new M1 Mac Mini and am getting exactly the same message except instead of ‘PlusKit’ it’s ‘SiteMap’.

Would be nice to know when either PlusKit or SiteMap will be updated for the M1 Macs. I can see both are currently for sale on the YourHead website.

Well it’s been 18 days since this post, so it’s obvious that he didn’t get back that week.

Those plugins from my understanding work, you just need to follow the instructions for running them under Rosetta. There’s a link for instructions in the kB article above.

Yup I had the same problem. I have Plus Kit and Sitemap and they both don’t work. This thing about running them on Rosetta is not cool. These program should work and it’s really not ok that YourHead is taking money from people and then their programs don’t work.

Thanks @teefers selected ‘Open using Rosetta’ and the error message has gone.

I hope it does get updated at some point SiteMap is a very useful plugin.

1 Like

These plugins DO work!

If you have a complaint about having to use “Rosetta”, and that “not being cool”, you should direct that at your beloved Apple. There they folks that decided to use a proprietary chip in some Macs.

There’s nothing on YourHeads site that says anything like “it runs in without Rosetta”.

Besides @mintyfreshsmile, did you purchase either of these products since getting your new computer last month?

3 Likes

Yeah I upgraded to a new MacBook Air with M1 and I was so excited to use Rapid Weaver on the new computer. I migrated everything and then saw I had outdated versions of Plus Kit and Sitemap. I purchased them both at that time. There was no warning when I made the purchase that they would not work on M1. My understanding is that Rosetta operates on a lower level or something and my whole reason for upgrading to a new computer was to stay up to date. I just feel taken advantage of and I’m really disappointed that I contacted YourHead support twice and never received a response. Other developers have responded right away, updated stacks that were not working and sent a new version or supplied code to fix compatibility issues - which has been very generous and very cool :wink: but YourHead hasn’t responded.

Rosetta exists for this specific situation - to allow code running on an M1, even when the code has not yet been optimized for the M1 chip yet. If you read about Rosetta, you find many examples, where users say that programs running under Rosetta on an M1 even outperform the original code on an Intel processor. Rosetta is a legitimate solution for your problem, and the ‘betrayal’ is likely only an unfounded perception in your head.

Isaiah from Youheads, arguably, is the person who single-handedly empowers this whole community with ‘Stacks’. He is also very gracious and generous with all his help on these forums. I am 100% sure, that he will get you sorted or even refunded, once he comes online again.

Which brings me to the most important part of this post. We are still living in pandemic times, and there was a time last year, where he struggled a lot with health problems. All of that is documented in these forums - I have no first hand knowledge. The fact he is not responding, should worry everyone more, than your perceived performance hit via Rosetta.

I recommend to watch the famous speech below to learn entertaining possible other perspectives, too. My apologies about my post sounding condescending.

4 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.