Publish time out + application call back


(martin james) #1

10.14.3
RM 8.1.7 all current. New sites, no extra add ons, no old software.
stacks, foundation, images
Published about 300 of 440 files before the time out.

Then the canceling publishing goes on for a very long time before stalling and I have to force quit. (no RW is not responding message on force)
Preferences set to log, no logs available to send…

It could be I am uploading lots of images.

thanks marty


(Guy Woodland) #2

What are your file sizes?


(martin james) #3

Guy Maybe my files were too big.


(martin james) #4

Yesterday I started the morning out by having my host redirect my sites to https.
As soon as I received the message confirming the redirect I went into the general and publishing settings and changed the web address to https://
Cleared cache, etc.

Unfortunately I have not been able to successfully republish.


(Guy Woodland) #5

Have you checked your php upload settings? And maybe resized your image files?


(martin james) #6

Hi Guy. I tried a lot of different things. Then after trying and trying I settled on a strategy of simplicity. I remade one of my sites into one pagsite with just a couple of pictures.

I am all current on all software + 8.1.7 beta.

When you try to publish and it publishes part way then stops, then you have to force quit. After hours of that you try to tweak settings, settings which were probably is not the problem but actually probably contribute to more problems down the line.

I thought that I had waited long enough for RW8 to stabilize. In the days before my current problem I did have my host redirect to https and also change the php to 7.2

My sites were redirected by the host to https, but I was unable to republish. So maybe some mismatch.

Then for 1/2 day it published.

Now it doesn’t publish.

When it worked several weeks ago we purchased GoCMS and made test bog posts. I used very low quality pictures to test and lourm ipsum to test the CMS functions.
I guess but I am not sure that the blog pages try to repopulate to the page with the folder called page1 or page2 etc. On the general settings that might be the box for entering text under where you enter the Browser-Title.

I can’t test that now since it won’t publish. I asked a while back for info on a step by step on how to FTP into the host server. I would need a step by step so I would know if there were index files or playlist files that need special treatment.

Very Frustrating. It doesn’t publish and I get less than helpful errors that say “application call back” or “Upload failed at start before it took off” Or “can’t connect to the server” (tests ok with either https://www or https://)

Then later I have tried to sync with a ftp program over FTP and the connection looks fine but then I get a 522 "the ---- item can’t be copied disk full please upload later.

Very frustrating.

I am not trying to publish an important work of art site here. I am just trying to publish the simple one page testing site, so I can make sure everything works before I start investing the hours.

Guy on your php question. I thought that box came as html by default. I have a gocms blog in the works, and maybe a photo gallery in the future, so maybe it would be better to start out with php in that box? When I went to change it it gave me an error warning. The box was blank, then I out in php and it gave a warning.


(martin james) #7

I have tried to change to php, now only 2 images 100k each.

thanks for the help

Marty


(Neil Egginton) #8

Could the issue be that you have reached the storage limit on your hosting account? If you can’t FTP the files with an external programme, that would suggest the issue is at the hosting end.

If you have uploaded a ton of large photos to your server before but haven’t ever deleted them, all those files accumulate.

I would suggest finding out if you have reached your storage limit, then delete files on the server you no longer need.


(Jan Fuellemann) #9

Can you call your provider? It seems you have used up the space on your server. You have to delete files on your server or ask for more space before you can publish further.


(Guy Woodland) #10

You’ve got to knowledgeable people below offering advice. I agree in that when I’ve had issue with RW exporting and resorted to using an FTP client the ftp client works. I agree with the advice and would check your server either by checking your CPanel or your admin section or putting a call in. Be interesting to see the outcome.


(Doug Bennett) #11

You haven’t said what ftp program you’re using, but a common ftp error from most ftp clients for out of space (Disk quota exceeded) is a 552 not the 522 you mentioned. Are you sure it was a 522 and not a 552?

I suggest you follow @NeilUK’s advice if that fails then more information would help. I would suggest you get the stand alone ftp client working first, then go back to publishing within RapidWeaver.

  • What ftp client are you using?
  • What is the hosting company?
  • Could you give a screenshot of the error message the ftp client is giving?

RapidWeaver 8.1.7 Public Beta
(martin james) #12

Thanks to the people who have written to try to help me.
I think I was having multiple problems at the same time which was confusing.
First I was nearing the storage limit on my hosting account.
Because of that some smaller sites would publish but other larger sites would not.
Unfortunately when publishing failed we were receiving the “application callback” error which we didn’t understand. In addition rapidweaver publish logs would not work and every time publishing failed we had to force quit the program.

In addition I had just asked my host to redirect to https, which then caused error messages because we still has http content that had not been deleted by republish.
Some of the errors were from Go-CMS since we had originally published test blog posts from http. I think the Go-CMS content might be tied to a file called page1, so if you make test blog page, then later that test content might still be on the server waiting to populate any page with the default folder name of page1. (correct me if I am wrong)

The Cyber duck program I had used before was not working for me. I have since purchased “Forklift 3” which is a FTP program with split screen. Very helpful for bulk renaming, plus you can make the font much bigger so drag and drop works better.

Although I have no idea what half of the files on my host are I was able to use the FTP program to delete many files and content that were on the server but unused.

I guess I probably thought that when you have a site with a number of pages and then you republish with less pages, that those pages that you didn’t republish would be erased.

Now I believe that in order to get rid of no longer used content on the host that I need to use a FTP program and delete unused files.

I could use a link to a tutorial on understanding to do housekeeping on all the different files in a cpanel hosted site.

Also if there is something I need to do to activate my publishing error logs…

Thanks Marty


(system) #13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.