RW publishing issues


(Charles Crawford) #1

I have my path set to the folder where my pointer is directed with my hosting company. Example the folder xyz when I publish with RW it creates a second folder in the back end of the site in the hosting company file manager. So I upload to /xyz and RW creates and puts all the files into /xyz/cuz anyone know how to fix this? I don’t want it adding a second folder.


(Rob D) #2

You don’t need to create any special folder on your server to contain your website files. If you do, you should know exactly what you are doing, because that, most likely, is the cause of your problem.

Typically, the folder containing your website is already created for you by your hosting company. You just need to point RW to that folder (in your Publishing Settings). Usually, that folder is named /public_html/.

P.S. Below is the screenshot of my domain’s directory on my host’s server. The red box indicates the folder where my website files live.


(Charles Crawford) #3

Rob so my hosting is with fat cow. On their system in the control panel we have 2 sites. So the main folder is the other site and my company site is in the crawfordleatherworks folder. It’s here that I am getting a second CL folder not on my computer. I have everything set to the crawfordleatherworks folder when I publish in RW it creates a second crawfordleatherworks folder crawfordleatherworks/crawfordleatherworks and puts all my files here so nothing goes live. If I change the pointer to that second folder it creates a third

Thanks

Charles


(Rob D) #4

I see. This is a problem that could be solved by someone with a better knowledge than mine of how servers work. Perhaps the best places to get help are your host and RealMac support. @LaPan, @simon.


(scott williams) #5

It sounds like you have the folder set in general settings and also in the home page.

Show a screen shot of your site publishing settings and a screen shot of page inspector folder/file settings.


(Charles Crawford) #6

Here are the two shots requested


(scott williams) #7

why do you have /crawfordleatherworks in the path twice?

That’s why you are getting /crawfordleatherworks/crawfordleatherworks/home for the home page folder

normally you would have /crawfordleatherworks for a path and nothing in the folder for the home page/landing page. other pages would have folder names i.e. about or contact etc., etc.


(Charles Crawford) #8

Originally I just had crawfordleatherworks for the path. When it started making crawfordleatherworks/crawfordleatherworks I changed the pointer and the path to it but then it just created 3 crawfordleatherworks. If I could get it back to crawfordleatherworks and have it not create crawfordleatherworks/crawfordleatherworks folder I would be all set. I don’t get why RW is creating a new folder and putting the files there. I did not set it up to do that


(scott williams) #9

That’s exactly what you told it to do. If you put a folder in the publishing path or in the page ui and it doesn’t exist, RW has no choice but to create it to publish the files there.
I hope that makes sense.

By default RW will publish to your root folder. Adding folder names in the path publishes files starting at the last folder in that path, then looks at the page ui if there is a folder there it adds that on to the end of the publishing path


(Charles Crawford) #10

Now I am confused lol so when we started the crawfordleatherworks folder is
where I wanted everything to be for the Cl site. The file / is where my
wife’s site is for her photo business. With fat cow web hosting you have
one file manager in the control panel whether you have 1 site with them or
20. So how should I set this up? I thought by setting up a
crawfordleatherworks folder but it RW created a folder in file manager
crawfordleatherworks/crawfordleatherworks. So how should I have this set
up?


(scott williams) #11

okay so here’s what you do:
Get rid of the unwanted files and folders on your server

Set the publishing path: /where ever you want your home page to live - /mysite
home page folder (page inspector): leave blank
home page (all pages really) index.html (or .php if needed)

other pages (page inspector): name these folders what ever you want the URL to be - about, contact, gallery etc.

publish just the home page and check the sercer, you should have: /yoursite/index.html (or php) + a few other files.

Everything good? - Publish all


(Charles Crawford) #12

So I followed your advise and everything looked good. Files were going where they were suppose to so I thought everything was right with the world until I tried going to our live site. When I go to the homepage I see a white page that says "error 403 forbidden you don’t have permission to access / on this server. The path is set to /crawfordleatherworks so I don’t get this now.


(scott williams) #13

Is index.hrml in the /crawfordleatherworks folder?

Do you have Cpanel access?
What does it say your docroot directory is?

can you show a screen shot of the folder structure on the server
It acts like your folder structure is not within your docroot folder, easy fix if that’s what it is


(Charles Crawford) #14

Ok so the index.html is there but it’s gone back to adding a second folder. In the file manager there is my crawfordleatherworks folder and when you open it up there is another crawfordleatherworks folder and this is where all the files are

This is my publish settings in RW

Home page page inspector

In the control panel file manager for fat cow you can see the folders inside each other

And here you see the index.html file in the second folder with everything else.

For some reason when ever I reinput the pointer to /crawfordleatherworks hit save when I go back into the pointer it says
/crawfordleatherworks/


(scott williams) #15

Hi, unfortunately, I cannot read your screen shots. You can grab a screen shot in osX to your desktop by pressing:
Shift Command 4.

Some things to check: publishing settings can be set by pressing: Command 4
They can also be set in the Manage bookmarks - click the small arrow beside the publish button
the settings should be the same in both places.
Also, make sure the web address - set by clicking the spanner wrench then general should be just the url
That’s about all I can think of not being able to see the screen shots


(Charles Crawford) #16

Here is the RW publish Window

RW Publish

here is the control panel and file manager

Screen Shot 2017-08-30 at 11.48.50 AM

This is the pointer
![image|690x431]

(upload://bAPAGHATHKzT7t2sT8TGxJEuX83.jpg)Screen Shot 2017-08-30 at 11.48.50 AM


(scott williams) #17

Thanks, can you also show a screen capture of:
publishing settings (can be set by pressing: Command 4)
and
Manage bookmarks - details for that site - (click the small arrow beside the publish button)

It seems to me that if it is changing publishing settings back to /crawfordleatherworks/crawfordleatherworks/ one of these has to be wrong.


(Charles Crawford) #18

Hey Scott here are the publishing setting

!

here is the other part

17 PM|690x431


(Don H) #19

I think the login for ‘crawfordleatherworks’ puts you into the topmost ‘crawfordleatherworks’ folder. Since this is a sub account of your main account, that makes sense. That becomes the ‘root’ level when you login with the username.

Try leaving the Path empty in the publishing settings. Delete the folder in your file manager and try republishing.


(Charles Crawford) #20

Don
I have had to do another ftp user. If I leave the path blank and it puts things in the root folder won’t it over ride the other website?