Stacks 4 - Are You Ready?


(Isaiah Carew) #21

@Cyroscope

We keep all our old versions on the YourHead Archive – if you forget the URL there’s a link at the bottom of every page of our website.

This sounds more like it’s just a bug. If you send me the crash report, there’s a good chance I can fix it. :slight_smile:
Here’s our FAQ on how to send a crash report: https://yourhead.zendesk.com/hc/en-us/articles/115001860747-How-do-I-send-a-crash-report-

But do make sure to report any issues with compatibility to those developers. They may not be aware of the specific problems you’re having. And hearing it direct from a customer working on a real project always carries extra weight.


(Joe Martin) #22

I have it working in Stacks 4


(Isaiah Carew) #23

When random crashing occurs I would suggest cleaning up, upgrading, or just uninstalling unused plugins.

RW 8.x has been a bit rough on plugins and there are a lot of plugins that are not yet compatible with the latest RW.

I did a video not long ago all about the addons folder that might help in cleanup: https://www.youtube.com/watch?v=FcalwrsJt7g&t=1283s


(Nick Wilcox-Brown) #24

All working beautifully here - great work Isaiah!!


(LJ) #25

An excellent update with some really useful features! I am however noticing frequent RW crashes. This has been happening on a Depth project but not had time to see if it is just Depth or something else. Will test some other sites shortly and report back. If a crash report would help let me know and I’ll send one over.


(Neil) #26

Someone else has the same issue with Depth. Personally, RW + Stacks4 hasn’t crashed at all.


(Peter Hansen) #27

… it crashed a few minutes ago while trying to perform an ”undo” (cmd-z) after entering the faulty text into the ”Image plus”-stack by doobox.
(Rapidweaver 8.2.1, Foundation by Joe Workman - no poor Nick Cates and Depth here but pure Stacks4 and Rapidweaver)

Maybe its not only Nick C who’s the inly culprit here?

Yours

Peter Hansen


(Isaiah Carew) #28

Hi @Cyroscope,

I am looking for info about this crash. It seems elusive, I was wondering if you knew of a simple way that I could make it happen?

I’m able to use the Depth Theme and stacks without any issues so far. I’m wondering if it’s a particular setting that’s causing the crash, or perhaps if Depth is a red herring and the crash is something else entirely.

Isaiah


(Peter Hansen) #29

Dear Isiah!

Perhaps we never know. I have downgraded to stacks 3 and now everything works fine, no crashes.
Maybe the problem is my system? Maybe my system can’t cope with Stacks 4 since i experienced some crashes using Depth (Nick upgraded Depth last week) and

one crash using Joe Workmans Foundation after an ”undo” operation in connection upgrding this site: http://mkprod.se

I´m happy with stacks 3 and since i rarely build new sites - maybe one every 2 or 3 year - i better stick to a system that works for me.

If You able to work with ”Depth” without any problems…then lucky You! No hard feelings!

Yours Peter Hansen


(Isaiah Carew) #30

When people report problems, it’s my job to know. After 39 years of software development experience, it’s my best guess, and professional opinion that this is not a compatibility issue with Depth.

I’m not trying to run away from the problem, rather the opposite. I’m trying hard to take responsibility for it. I hate to see another developer have to take the wrap for my bugs. I’m pretty sure THIS IS MY BUG.

You to be implying that I think this is not a problem or not a problem with Stacks 4.

NOPE

I think this IS a problem with Stacks 4. I’m just trying to get some more info. There are only two people reporting this one (that I am aware of) – you and @manofdogz – and I think if I had a tiny bit more info about the problem, I’d probably be able to fix it.

the “undo” bug is well known (here is our bug tracker info about it – you can follow along, contribute and even see when we have planned to have it fixed and help us verify when we do fix it)
i spent all day working on this bug. we’ll have it fixed shortly. it is not related to Depth or Foundation or any other 3rd party thing. It’s just a stacks bug. if you undo a text change after closing a text editing box then it always crashes. it’s a bad one – but i should have it fixed soon.

If you’re happy working in Stacks 3, that’s great. We’ll continue to support Stacks 3 with any necessary updates etc. for at least another year. So there is no rush to move to Stacks 4. Only move when its useful to you – maybe never is the right answer. that’s fine too. :slight_smile:

But I do want you to know that I’d be happy to help you out any time – especially if you’d like to move to Stacks 4 again.

Isaiah


(Peter Hansen) #31

Dear Isiah,
I really appreciate your concern about your work as well as Nick. His themes (i got a few in my box) and projects are really great and and i have also told him that!

I also think that your stacks is a gift from heaven that facilitated my tentative attempts building websites! As i told you; i´ve also experienced a crash

using Workmans foundations in conjunction with a ”undo” (cmd-z) operation. I’m really sorry if I happened to stirring up things for you - you and Nick are really

great developers as well as great and sympathetic fellows! and I’m convinced you’ll sort this problem out!

(Last year i bought a ”theme” and stacks from another developer (no names-but maybe you suspect who) that appeared a bitt faulty. I reported that but but our

communication was really bad and frustrating!) Honor to You and Nick!

Yours

Peter Hansen

Horsikavägen 2

43082

Donsö

Sweden

http://peterhansen.se

tel: +46730897650


(Isaiah Carew) #32

Again. I feel I must reiterate that there is no evidence to suggest that Foundation or Depth have anything to do with these issues. Details about this bug can be found here.

It’s just an undo bug. I’ll fix it soon. :slight_smile:

Issues in new software are par for the course. Reporting problems is how bugs get fixed! I’m glad you reported things! Thank you. :slight_smile:

but…

If i could just ask one favor: when reporting issues in the future, please follow through with details. It’s so important. :slight_smile:

The most frustrating thing in the world to a developer is knowing vaguely that a problem exists, but not knowing enough to fix it. :pensive:

Isaiah


(studiozellige) #33

Hi @isaiah, have you updated the first official version of Stacks v.4 and where can I check the next updates? …
I think I will wait for the purchase of the Stacks update to ensure perfect compatibility with RapidWeaver 8.3 …
Thanks again for your great work … :wink:

Bonjour @isaiah, avez-vous mis à jour la première version officielle de Stacks v.4 et où puis-je vérifier les prochaines updates ?..
Je pense que je vais attendre l’achat de la mise à jour de Stacks pour m’assurer une parfaite compatibilité avec RapidWeaver 8.3…
Merci encore pour votre formidable travail… :wink:


(Isaiah Carew) #34

Bonjour,

I have. You can find stacks on our webpage: http://yourhead.com

Stacks 4 is working well in RW v8.3 beta currently – but waiting a while is a good precaution too. :slight_smile:

ce travail est ce que j’aime fair :slight_smile:
isaiah

btw: my son has his very first day in French class TODAY!!!
i’m so excited that i’ll finally have someone in the house to practice with. :tada::fr:


(Peter Hansen) #35

Dear Isaih,

Yesterday:

Here some details: Adding a stack - crash! Tweaking a stack (a footer) - crash! Deleting a stack - crash.- All in connection with Depth and solely with depth own stacks! (depth section, depth limit) - i already told Nick that.

Then I also tried stacks 4 with a ”module theme” by 1 LD - it flatly refused to work at all. I’m not a developer and therefore not acquainted with coding and far too old learning the subtleties of that particularly craft.

Breaking the waves has it costs - especially when things become more complex. I usually lurks behind and joining the throng when the fence is up, the cows safely home, the roof is waterproof and the motorway…

Today:

You wrote ”please follow through with details. It’s so important.”…ok! I reinstalled the stacks 4 - this time RW downloaded 4.01…well well…the the Depth bug is crashed…well. Did some tweaking, loading stacks and it was ok

in the beginning, BUT after applying Pro Columns (Doobox) and within the columns Moviebox2 by Workman and a ”Depth Section” in other. After clicking the inspector dot in order to do some tweaking on the ”Depth Section” it crashed!

(During my former tests i used other stacks as well - with the same result—Crash!)

Isaih…now i spend a sunday morning doing some beta testing for You…i think you owe me a beer (or two)! I’m maybe the only one in the universe having this particularly problem - if that’s the case - You don’t have to worry at all!

I´ll reinstall stacks 3, rely on that and go on finishing a new website using Depth for my wife! I put Stacks 4 to rest in a virtual cupboard somewhere…maybe ill wake it up sometime…

(her current website made by Workmans Foundation some years ago look like this: http://mkprod.se)

Again…you asked for detailed info?..well - you better read the enclosed text document!

Yours sincerely

Peter Hansen

(Attachment Crashreport.rtf is missing)


(Isaiah Carew) #36

@Cyroscope I’m sorry I upset you. It definitely wasn’t my intention. I think it would be best to let the conversation drop now. Don’t worry about sending me anything else. I think I’ve got this one covered.

If you do want help, I’d be happy to. The support link is at the bottom of every page of our site. Or you can DM me here, or whatever suits you.

I’m afraid I couldn’t read the document. I don’t think this forum allows file attachments. But again, that’s OK. Don’t worry about it.
If you do want to share something, just head over to my site click the FAQ link – it’s at the bottom of every page. The top FAQ on our site is how to share your project and addons with our support folks.

Good luck with your site,
Isaiah


#37

I don’t even use Rapidweaver that much anymore but I couldn’t resist this cheeky purchase. Looks great so far. Good work @isaiah


(Kevin Atkins) #38

Hi Isaiah.

Sorry to hang my issues off the back of this convo, but I have also had the ‘Undo’ bug, although it’s entirely random, and very quick. However, that’s not my main worry.

I’ve just experienced an issue with Stacks 4, and I now can’t open any project with a Stacks page – which is all my projects.

I’ve emailed a support ticket to you, so I won’t go over all the troubleshooting and uninstall / reinstalling I’ve been doing this morning, but, basically, everything was fine last night, but broken this morning.

Whenever a project using Stacks is opened (by any method), RW just hangs with a beachball, and stays that way.

I do have many plugins, so I stripped RW back to bare minimum (not even factory themes etc), and just installed stacks, but no joy. I tried reverting to Stacks 4.0.0, but that didn’t work (it threw an error saying stacks needed updating as the project was made with a newer version – and then it hung as usual).

I’m sure this issue is on my Mac, but that it’s appeared overnight, and that it affects every Stacks project, no matter what else is turned on/off in RW has left me stumped, and concerned.

My main worry is that I’m working on a major website, and we’ve just taken the plunge to go with RW and Stacks as our platform, and I can’t access any of my work, or move my project forward. I also cannot update existing sites, which need regular updating, as they all use stacks.

If it helps, the only error that I see appears in Console, and references “com.apple.AddressBook.customPropertyDamageDetected” but nothing else. No other logs or warnings.

I’m at a loss as to what to do now. I’m currently trying to test a Stacks project in another user account, but even that is lengthy, as I have to find all the original serials, upgrade serials, plus any stacks or themes required for my projects.

Any suggestions greatly accepted!


(Kevin Atkins) #39

I’ve had a further go at bringing my projects back to life, but no luck.

I created a new user account, and (eventually – after finding serials, etc), tried a fresh RW install, but this time with stacks 4.0.0.

I can open a stack project now (admittedly, without all the addons that I’ve yet to copy across), but I get this in the edit window:

… so I can’t work on anything.

In a flash of hope, I was presented with a dialog asking for permission to access my Contacts (something about RW accessing web / email details for the default site), so I purposely disallowed this, so it would – hopefully – not try to access my contacts , and throw the com.apple.AddressBook error, above. No luck. It still hangs, with or without contacts permission.

So, I’m now stuck unable to update any of our company’s websites. Very concerning.


(Jan Fuellemann) #40

Since this happened overnight: did anything change in your companies network access/firewall update for routers or switches? Can you try a different network with your Mac, e. g. at home?