"This document could not be saved"


(Claus Fuchs) #1

Hallo. Seit RW 8.1.1. kann ich plötzlich meine Projekte nicht mehr sichern und auch der Upload auf den Server klappt nicht mehr. Wieso kann ich meine Projekte plötzlich nicht mehr sichern? Gibt es irgendwo das berühmte Häkchen, das man setzen muss, damit es wieder funktioniert? Ich habe einen neueren iMac mit 10.14.2, müsste also gehen. Ich habe probeweise ein neues Projekt erstellt mit 3 Seiten. Nach 4-5 Bearbeitungsvorgängen geht auch hier das “Sichern” plötzlich nicht mehr. Was kann ich machen?


#2

Bei einem meiner Projekte tritt der Fehler ebenfalls auf, egal auf welchem Weg ich versuche zu speichern. Mit RW 8.1 konnte/kann ich das Projekt problemlos speichern.
In dem Projekt gibt es keine „exotischen“ Stacks oder andere Besonderheiten.
Da mir RW 8 noch immer zu unsicher ist, habe ich erst drei Projekte auf RW 8.03 umgestellt. Dieses eine 8.11-Projekt war ein „Betreibsunfall“, da ich beim Speichern mit 8.1 noch nicht wusste, dass es kein Zurück auf 8.03 gibt, vom Backup abgesehen (ist vorhanden).
Diese vielen Fehler nach der langen Betaphase irritieren mich doch zunehmend.


(Jan Fuellemann) #3

Bitte direkt an den Support von RealMac wenden:
support@realmacsoftware.com


#4

Ich habe mich inzwischen an die Arbeit gemacht, und das Projekt (fast) neu angelegt:
In RW 8.11 ein leeres Projekt angelegt,
alle Seiten aus dem Projekt 8.03 einzeln in das neue RW 8.11 gezogen,
Theme und Masterstyle unverändert übernommen,
die File-Namen unverändert neu eingegeben,
alle Verlinkungen neu angelegt,
die Generaleinstellungen unverändert übernommen,
den individuellen CSS-Code unverändert übernommen,
die Publishing-Einstellungen unverändert übernommen.
Jeden Zwischenschritt unter neuem Namen abgespeichert (test02, test02…)
Zum Schluss unter dem alten Namen mit einem kleinen Zusatz abgespeichert (811 Wardenburg 2019-01-28b ABC 4.rw8)
Ergebnis: Das Projekt konnte gespeichert werden!

Nun hoffe ich nur, dass das nicht bei allen anderen Projekten der Fall sein wird, denn dann würde ich bei der Vielzahl der Projekte gut einen Monat brauchen.


(michael m.) #5

Nachdem ich mich anfangs gefreut habe, nicht davon betroffen zu sein, habe ich den Fehler nun auch bei einem Projekt, das sich zuvor einwandfrei sichern liess.

Was nun…?


(michael m.) #6

Ein neues Projekt anzulegen und die einzelnen Seiten reinzuziehen, wie von @Volker vorgeschlagen, kann natürlich nur eine Notlösung sein. Aber vielleicht hilft es, RapidWeaver in den Systemeinstellungen unter “Sicherheit” umfassende Rechte für den Festplattenzugriff zuzuweisen.

Jedenfalls konnte ich das Projekt, das gestern den Fehler zeigte, damit wieder speichern


#7

Bei mir hilft das leider nicht.


(michael m.) #8

Dann sollte der Support ran - das kein kein Dauerzustand bleiben


#9

Inzwischen habe ich herausgefunden (?), dass es sich mit großer Wahrscheinlichkeit um Projekte handelt, die vor RW 7 erstellt und dann jeweils in die neuen RW-Versionen übernommen wurden. Zu 100% sicher bin ich mir allerdings noch nicht, da ich das noch nicht bei allen Projekten überprüft habe und auch nicht immer genau weiß, welches die erste RW-Version bei der Entstehung war. Mit RW arbeite ich nun schon seit der Version 2.

Ein betroffenes Projekt habe ich mit einer Beschreibung an den Support geschickt.


(Jan Fuellemann) #10

Hi, lt. RealMac ist das noch nicht die Ursache und sie raten davon ab, das so einzustellen. Dafür bitten sie um Projekte, bei denen dieser Fehler auftritt. Diese bitte an support@realmacsoftware.com senden…


(michael m.) #11

Kennst du einen Grund, warum das nicht so aktiviert werden soll?


(Jan Fuellemann) #12

Nein, nicht wirklich - außer eben, dass dies nicht immer hilft :slight_smile:


(Sebastian Schiller) #13

Seit der Umstellung auf RapidWeaver 8.1.1 (20595) bekomme ich dieselbe Nachricht.

Bevor ich die Fehlermeldung zum ersten Mal erhalten habe, hatte sich RapidWeaver “verabschiedet” und einen Systembericht erzeugt (Konsole/Systemberichte). Diesen habe ich gerade an den Support support@realmacsoftware.com geschickt.

Mein aktuelles Projekt hat eine Größe von 1,15GB, was daher zu groß zum Verschicken an den Support ist.


(Jan Fuellemann) #14

Wow - wie kommst Du auf so eine Größe? Ginge trotzdem mit Wetransfer.com, aber warte mal, was der Support sagt…


(Sebastian Schiller) #15

Support-Feedback: “We’re investigating an issue that we believe is causing this, and hope to release an update very soon. In the meantime, as a workaround, you can try going to File Save As and choosing a new name and directory to save your file.”

Diese Rückmeldung vom Support, dass als Workarround “Save As…” verwendet werden soll, klappt leider nicht bei mir. Auch das neueste Update 8.1.2 hat den Fehler nicht behoben. Derzeit bin ich wieder auf die Version 8.0.3 (20142) zurückgegangen, welche ich noch hatte.

PS. Habe einiges an lokalen Inhalten (Videos, Texte usw.)


(Ingolf Behrens) #16

Habe den Fehler gefunden, es handelt sich um alte, fehlerhafte Einträge in der contents.plist. Die findet man, wenn man sich von dem fehlerhaften Projekt das Archiv anzeigen läßt. Die Datei contents.plist ist eine simple Textdatei und läßt sich mit jeden Editor bearbeiten.
Es hilft, wenn man das Support Log löscht und dann das fehlerhaft Projekt speichert, anschließend das Support Log speichert und sich die Fehlermeldungen ansieht.
Die Dateien, die da aufgeführt sind, sucht man mit einem Texteditor in der contents.plist und löscht die Einträge, natürlich immer das gesamt TAG. Dann wieder speichern und gut is …


(Jan Fuellemann) #17

Hast Du das dem Support gemeldet? @tpbradley


(Ingolf Behrens) #18

Nein, habs einfach korrigiert, tritt nur auf, wenn man vor der Konvertierung von 7 auf 8 Ressourcen gelöscht hatte, die in eigenen Ordnern gespeichert waren. Bei mir waren es verwaiste mp3.


(Jan Fuellemann) #20

Wäre bestimmt auch wichtig für andere :slight_smile:


(Ingolf Behrens) #21

Darum habe ich es ja hier gepostet, mein Englisch ist eher … na ja.