Unable to access cpanel and publish website updates


(Ginger Hanson) #1

I’m having problems with RW connecting with my host service. I’ve spent several hours on the phone with MacHighway and so far they haven’t discovered what’s happening although they have checked everything under the sun. The 3 techs I’ve talked to keep calling it an “uncommon” situation.

Please bear in mind I use my Mac exactly how Steve Jobs intended–as a tool to get various things done. Just as I have no idea how my microwave works, I don’t have a high degree of knowledge about how my computer works!

The issue was discovered when I tried to update my website (10 days ago!) and wasn’t able to connect. The tech had me try and access the cp22 account with various devices (MacMini, Mac Pro laptop, iPad Air, iPhone 6SE). If anything connects, I get the “Sorry! Please contact your hosting provider” message.

Although I couldn’t access the cp22 by typing it into the computer, I was able to access it once from my website online (via iPhone & Verizon and off WiFi system) by adding cp22 to my domain name in Safari. Alas, I can’t do that any more.

Over the past week, my website has been either a 404 failure page or accessible on various devices. As of today, the website appears to be online on every device except my MacMini (which of course is where my RW software is located). The MacMini consistently gets a 404 failure page, but oddly, I can access my website via my Project page/View/Visit Published Site on the MacMini (OS High Sierra 11.13.4) RW 7.5.5)

The folks at MacHighway said they are working on it, but I haven’t heard from them in several days so I doubt they are losing any sleep over it.

I’m not sure if something is set wrong in RW or at MacHighway or somewhere in between. It’s as if my computer is knocking on a closed door. Fortunately, people seem to be able to access my website, but I can’t do any updates or republish.

Any suggestions would be highly appreciated.

ginger


(scott williams) #2

impossible to help without the url of your site


(Doug Bennett) #3

Not sure what that is(cp22).
Seems you are having a publishing problem?
What happens when you try to publish?
Have you tried the test button?
Could you provide screen-shots of your publishing settings?


(Ginger Hanson) #4

Sorry Scott! It’s at www.gingerhanson.com.
Doug, cp22 is the cpanel where the RW files are located on MacHighway. I’m not sure if it’s a publishing problem or more of a connection problem. The test button and browse buttons both time out and say they are
FTP unable to connect with the server.
Offline.
Offline.

The publishing settings have been checked by three MacHighway techs, reset a million ways. Right now the tech had me set to FTP, with MacH’s IP address as the server, connection with Average connection, my user name and password, and /public_html/gingerhanson.com and passive mode (although I did try extended, no luck).

I’ll see if I can get a screen shot in here. Oh, and I downloaded cyberduck and it timed out also. I’ll post this and see if the screen shot attached.

FTPScreenShot|642x500

thanks for your help!

ginger


(Ginger Hanson) #5

Hmmm, let me try again.

I think I erased the ! point on the first attempt. Let’s see if this works.


(Doug Bennett) #6

I don’t use MacHighway but looked at their help area. They have a RapidWeaver section. It looks to be for an older release.

  • They suggest you use Passive Mode (you have Extended Passive).
  • They say to set your path to public_html (you have /public_html/gingerhanson.com).
  • You have the connections set to 3-average, I would change that to 1 to test.

I would set to Passive Mode Change the connections to one, clear the path (blank) and hit the test button.
If that connects, then hit the browse button (with a blank path) and select the public_html folder.

https://customers.machighway.com/index.php?rp=/knowledgebase/98/RapidWeaver-Publishing-Instructions.html


(Ginger Hanson) #7

Thanks, Doug. I’ll give it a try. I changed to Extended b/c that’s what Dan had in his guide to FTP connection issues. I also added the / to public b/c the MH tech told me to do that. I’ll follow your suggestions and see what happens.


(Doug Bennett) #8

Might try this:
http://www.gingerhanson.com/cpanel
or
https://cp22.machighway.com:2083/


(scott williams) #9

I can access your site fine. If you can’t get to it from the browser on your Mac mini. Try clearing your cache first. As for the publishing I would follow Doug’s advice and report back.


(Ginger Hanson) #10

Doug, I’m able to connect to the cpanel via my website, but my website first goes to 404. If I type the address into the Safari browser bar it will connect to the website and go to the cpanel when I add that to the address. Neither my MacMini or my MacPro will connect to cp22 @MH. They both report that the server isn’t responding.

And yes Scott, we’ve cleared the Safari cache repeatedly, but I’ll do it again. And try accessing MH again.

thanks!


(Ginger Hanson) #11

Did I forget to tell you that I changed the info in the publishing settings but still no connection.


(Doug Bennett) #12

I’m able to get to your site and navigate fine, on Chrome, Firefox, and Safari.
When I select https://cp22.machighway.com:2083/ I get this:

I don’t have a login with MacHighway, but do you get that screen?

What did you get when you hit test?


(Ginger Hanson) #13

Okay, that’s really interesting. Yes, that’s the cPanel page. And yes, we’ve tried Firefox and Chrome with no good results. I’ll try them again to see if they’re working now. I just downloaded Chrome this morning when I was talking to Apple Care.

Test and Browse pretty much do the same thing. They come back with being unable to connect with the server and off-line offline.


(Ginger Hanson) #14

Okay, I can’t access MacH via either other browser. Chrome listed some things to check, one of them had to do with checking the proxy setting in Network.

It says Bypass proxy settings for these Hosts and Domains: *.local, 169.254/16

Use Passive FTP mode (PASV) is also checked. Since I can’t remember going to this page, I’m not sure how that info got there other than the usual the computer did it.

Also, Chrome lists rebooting the router (which I asked two techs about last week!). I’m going to do that and see if anything changes.


(Ginger Hanson) #15

Rebooting router didn’t change life. Sigh.


(Doug Bennett) #16

Okay,
We need to take this one step at a time. Sounds like you are having multiple problems.
Let’s start out with access to your site:

When you MacH, are you trying to get to your site, or the cPanel or https://www.machighway.com/ ?
What happens?
What are you posting here with?


(Ginger Hanson) #17

Yes, I think I am having several issues! I can access my website on my MacPro, iPadAir, and iPhone, but not using myMacMini. I can access MacHighway.com on all devices.

On the MacMini, I get the 404 failed to connect page, but I can put my web address in the Safari search bar and it will take me to my website.

I don’t seem able to connect to the MacHighway cPanel address via any device.

I use Safari.

I have no problem connecting to any other website, shopping, banking, etc.

I see two major problems. 1) My website is inaccessible to my MacMini which houses the RW software so I can’t update. 2) My connection to the cpanel times out if I go directly although I seem to have 'back door" access it.

Here’s what I can do. Open RW project/open View /click visit published site. It loads my website. If I attach cpanel after .com it takes me to the cpanel with no problem!

Does that make sense?

ginger


(Ginger Hanson) #18

I’ve been going thru Dan’s guide to FTP and figured out how to get the log. It appears there are some errors in publishing. Not sure if they would prevent the FTP from connecting and also am not sure where they came from since I don’t remember doing anything except trying to add a link. Here’s what I got

2018-06-12 16:20:51.148 RapidWeaver 7[796:38602] ==============================================================
2018-06-12 16:20:51.148 RapidWeaver 7[796:38602] NEW LAUNCH (2018-06-12 21:20:51 +0000)
2018-06-12 16:21:06.991 RapidWeaver 7[796:38602] Loading page:‘Home Page’ with plugin:‘YHStacksPlugin’
2018-06-12 16:23:38.849 RapidWeaver 7[796:42361] failed to resolve bookmark with error: Error Domain=NSCocoaErrorDomain Code=259 “The file couldn’t be opened because it isn’t in the correct format.”
2018-06-12 16:24:24.590 RapidWeaver 7[796:38602] Loading page:‘Home Page’ with plugin:‘YHStacksPlugin’
2018-06-12 16:49:32.746 RapidWeaver 7[796:76123] failed to resolve bookmark with error: Error Domain=NSCocoaErrorDomain Code=259 “The file couldn’t be opened because it isn’t in the correct format.”


(Doug Bennett) #19

How are you accessing and getting a 404 if you aren’t typing the web address in?
“Safari search bar” is not a separate thing, but is address and search bar.


(Doug Bennett) #20

Great,
Have you tried Publishing to a local folder?