UNABLE TO UPLOAD is what it says

My server people changed a couple things around. I entered the new information into my site settings. And now even though the test says that it works, all I get is unable to upload. No reason given, just unable to upload. So I’m kind of stuck. Test says OK and when I actually do it it’s not OK. I’ve never really understood that.

Any help would be welcome

we need a little bit more detailed information from you in order to help - such as

  • publishing method
  • number of connections
  • the name of your hoster
  • which things have been changed
  • other info you think could be important

In the meantime, can you test your upload with a dedicated FTP client e.g. Cyberduck? These programs usually are a bit more forthcoming with error logging.


See attached. And Filezillah and cyber duck both work.

What has changed is the “server.” It was a long IP address. It was changed to what you see on the attached.

The host people are siteground.

Ah, maybe try this…

Press the “Browse” button by the Path field and re-choose the folder, then re-try publishing.

Just did. Still “unable to upload”

Change the path to just /public_html or public_html

Just did. Nothing. Sigh.

It begins to and then… stops and tells me Unable to Export

Maybe they also switched from FTP to SFTP. Did you try changing the Publishing Method to SFTP?

Tried that. No go. :man_shrugging:

Try to publish only one page. Right click on the page and select publish. Next check with your Hoster if there is enough space available at your hosting server…

That’s actually what I’ve been doing. I have a sub site connected to my main site. I was able to upload from there. In the same way you advised. Just uploading a single page. But my main site gets the “unable to upload” message every single time.Except for the pathway they are identical settings. And I’ve tried every pathway I can think of. Obviously except for the correct one.

I’m wondering if the publishing setup is fine, and it’s the project at fault and RapidWeaver is having trouble exporting a resource. Can you export your site locally, does that work?

Good call. It does not. I tried exporting to my external hard drive and it stopped almost immediately and said Unable to Export

Make a backup of your project file, then delete the last page, and try to publish locally. Do this to each page in turn, once it successfully publishes locally then you know that last page you deleted was the issue.

Once you know what page is causing the problem, you can start removing the resources on that page.

This way you can narrow down where the issue lies and resolve it.

Hope that helps.

Sigh… thank you…

And do you mean Export Site…?

No luck. I eliminated one page at a time from the bottom to the top and then I reloaded everything and eliminated from the top to the bottom and even when I got down to one page it wouldn’t export. Unable to export.

Could be a corrupt resource (look in the Resources Browser for suspect images/files).

Can you email me your project? If so, send it over to support@realmacsoftware.com, subject “FAO: Dan” and include a link to this forum post (so I know what it’s related to), and I will take a look at it for you.


EDIT: You could also try switching the Mode, maybe try Extended Passive. Worth a shot.

Here are my settings since Siteground moved me onto Site Tools. They are working now but I have to flush Dynamic Cache from Site Tools every time I make a change so not at all happy with Siteground at the moment.

@MartWaring we’re moving to Chillidog and would recommend anyone having hosting issues do so as well.

Greg at Chillidog know RapidWeaver and will look after you!

1 Like