Yuzool Themes - anyone have big love for this developer too?


(Twitchin Kitten) #1

Anyone else finding this guy to not ever answer support requests? I purchased Cart 2 from him and have been asking for support for his broken item repeatedly to no avail.

Is someone fact and quality control checking things from developers that are sold through the Rapidweaver site or is it a “buyer beware” policy?

Yuzool Themes has a no return policy of digital items and I can understand that, but if you’re going to sell an item and offer support for it, then you should actually reply with some help or offer refunds on things that flat out just don’t work.

I’m so livid I spent $40 on something I can’t support for. Does anyone have another way to contact this developer other than his site or via email?


(Konstantijn Van Calster) #2

I suggest you send Michael a private message on @yuzool. Keep in mind that he live in Japan and if I remember correctly he have a day job, so it takes a while to respond. I know it is difficult to contact him sometimes and it is even frustrating, but apart from this he is ok and I guess he will try to solve it. By the way, the Cart 2 stack is an excellent e-commerce solution, I hope to see more Cart 2 features in future updates. Cheers


(Jason Bostick) #3

I’ve generally had good experiences with Yuzool. He’s responded on this forum several times within the past 12 hours or so, so he’s not MIA or anything. I’m sure he’ll get back to you.

What is the issue with Cart 2? I only have minimal experience with it but maybe someone else can give some direction while you wait on Michael.


(Twitchin Kitten) #4

Yeah I’ve bought things in the past from him without issue. I’ve been trying for a month now to get in touch and used email directly and via his website and all I get is an automated reply on how he’ll get back to me within 5 days. I started this in October. I really wanted this site up and running so I can sell for the holidays and it looks like it’s not going to happen.


(Twitchin Kitten) #5

The issue is that nothing works! The whole cart is broken or I’m just doing things wrong. It seems pretty obvious on how to set it up and nothing is happening.

This is the issue - copied from the myriad of emails I’ve sent out. You can look at the site held in a temporary directory and play around. Just don’t buy anything if it happens to work. I haven’t looked at it yet today, I’m doing a million other things at once lol.

have the cart set up and the view cart button should be on the right, and it’s on the left when you publish live.
_ add something to my cart and NOTHING happens. _
_ view the cart and NOTHING happens._

_ have everything set as per your instructions and this is getting ridiculous. It’s been 5 hours I’m working on this and getting no help from you makes it worse._

Site: https://badwolfdesigns.net/shop/

_ have a “success” and “cancel” page set up as per the (very poor) instructions as well._

I need to have some variables added in but everything is so big and the amount of variables I need to add would make my cart ridiculous.

I sell necklaces and want to give the buyer a choice of charms to add. Is there any way of allowing them to input an item number instead of me having to list each variable individually? I have over 100 charms to choose from and that would make shopping very inconvenient. Already the cart is not really good because images are not “clickable” allowing the buyer to see an image more closely if they are on a desktop computer. This is causing me to add a gallery to the store which is just overkill on images and server space.


(James Bond) #6

I use Cart2 extensively, and have no issues at all. Michael, like a lot of the RW devs can be a bit slow at times, but it’s the nature of the beast when most are making/supporting things part-time.

If you want to share you’re project I’m happy to have a look at it.


(Twitchin Kitten) #7

I’ll be happy to share. How can I send you my project? I’m not uploading it here.


(Doug Bennett) #8

Click on his icon,
and click Message

You probably will need to put the project on Dropbox(or similar)


(Twitchin Kitten) #9

thanks. I have my own servers so I’ll send him an upload link. :blush:


(James Bond) #10

As mentioned in the message, you need to share the project NOT a zipped copies of the exported files.


(René Schaap) #11

This reply got a red-card again from the admins: I had to delete the message i wrote @TwitchinKitten ! Succes with your project, i hope i helped out a little.


(klaatu) #12

Are you self hosting? What version of PHP are you using?


(Twitchin Kitten) #13

I’m using PHP 7.0


(Twitchin Kitten) #14

I just upped it to 7.2 and it’s still useless. SOMETIMES the “view cart” button displays the cart is empty even if I click an item to put into it, then it goes dead again.


(klaatu) #15

Looks like jQuery is crashing on your page; probably due to several versions being called:

<script type='text/javascript' charset='utf-8' src='https://badwolfdesigns.net/rw_common/plugins/stacks/jquery-2.2.4.min.js'></script>

and

'<script src="https://badwolfdesigns.net/rw_common/themes/qube/scripts/jquery-3.3.1.min.js"></script>

If you feel like trying something out…give these some thought:

  1. Create a new project using some sort of blank theme. Add the Cart stack with minimal configuration and publish. There are a tonne of blank themes floating around out there, try it in one of them and see.

  2. Try turning off the call to either the Stacks plugin jQuery OR the theme JQuery (if that’s an option). If the theme Jquery is not an option you could always export the page then delete the theme’s call to Jquery from the source then publish that. The point being that you are controlling which call/version is in play to see if that kills the error you can see in your console.

Either way a simple “publish” won’t cut it, you’ll need to do a full republish (all) or even remove the files from your server and publish from scratch.

Might be worth a try.


(Michael Frankland) #16

I think as @klaatu said it’s too many jQuery libraries firing on the page - but this wouldn’t be a problem with Cart Stack itself.

So please try with another theme as @klaatu suggested or try and take off other Stacks on the page.


(James Bond) #17

Got your project, and worked it thru.

In the currency setting for an item you had “$” changing this to USD seems to have fixed things.

Not sure if this is covered in the manual for Cart2, but worth mentioning to @yuzool that USD seems to need to be in caps, if I replaced the $ with usd it still didn’t work. Only USD in caps appears to have fixed it.

Hope that fix works for you @TwitchinKitten


(klaatu) #18

@TwitchinKitten
Well? Was that it then? After all that it was a setting wrong in the stack settings? Would be good to hear from you that indeed that’s all it was. Or otherwise?


(Michael Frankland) #19

Good find @jamesbond - you live up to your name :cocktail:
(sorry I bet you get that all the time :sweat_smile:)

The manual could do with that explicitly saying “capitals” but there are examples and link to the currency codes in the manual.

The Stack default currency is US$ written as “USD”

That would make sense that adding a $ there would mess up all the jQuery…

If this is indeed all it was (as is often the case), it was quite an ordeal for something as simple as missing a correct input. Thanks to @klaatu and @jamesbond for working through this :slight_smile:


(James Bond) #20

@yuzool It wasn’t really anything hard to see the problem. It took all of about 40 seconds.

Open project, preview, see the issue, add a new Item stack leaving the settings at default, preview, see the new stack is working fine, compare the settings between the not working and working Items stack, see the fact that $ was used instead of USD. Change the not working stack setting, preview, working, done. Literally, it was that simple.

What is really at play here is a complete and utter lack of any problem-solving skills, or even common sense, on behalf of the OP, instead preferring to just shout loudly until someone else steps in to fix their mistake.

Why they bothered to send in a support request for something so easy to fix is beyond me, but I guess it just goes with the territory RW nowadays.